Fresh RetroPie 4.8 Install

I just did a fresh install of RetroPie 4.8. Ran apt-get update && upgrade

Then ran the command curl -sS | bash

During the install the script stated:

Retropie does not seem to be installed. No worries, we can still set up the hardware side for you!

rebooted and retroPi does not see the PicadeX HAT.

Looking for n00b level hints. Thanks

No responses here or on discord :(
Trying to track this down. The section of code that generated this error is:

if [ $customcmd == "no" ]; then
        if [ -n "$pkgremove" ]; then
            echo -e "\nFinalising Install...\n"
            sysclean && newline
        echo -e "\nAll done. Enjoy your $productname!\n"
    else # custom block starts here
        echo -e "\nFinalising Install...\n"
        # add_dtoverlay hifiberry-dac
        if [ "$OS_NAME" != "RetroPie" ]; then
            inform "Retropie does not seem to be installed. No worries,"
            inform "we can still set up the hardware side for you!"
        cd $installdir/$gitclonedir
        sudo ./

I ran the following command to get the OS info that is being reported. Results also below:

pi@retropie:/boot $ hostnamectl
   Static hostname: retropie
         Icon name: computer
        Machine ID: 74b02a21da1f4b5e81e8a4ab97bbfaf1
           Boot ID: b370fb7f05ec4989beac031f49a3727c
  Operating System: Raspbian GNU/Linux 10 (buster)
            Kernel: Linux 5.10.103-v7l+
      Architecture: arm

In the install script from GIhub there is a check:

osreleases=( "Raspbian" "RetroPie" ) # list os-releases supported

Also noticed there is multiple references to the variable $OS_NAME. however I do not see where it is declared. Am I missing something or is this a bug in the script that is forcing the $OS_Name to be null and thus the script is not installing?

I was able to set a system variable OS_NAME=RetroPie and re-ran the script from GIT and the install works now. Not 100% fully tested at this point but at least RetroPie sees the “New” controller