Getting no sound


#1

I get no sound at all on a fresh Retropie install on my Picade. Even
when I set Audio Output thru the 3.5 jak. Not getting sound with
headphones either. First, I was getting a lot of noise, I did the
disable_audio_dither=1 and it really disappeared, but still no sound at
all. Any ideas?


#2

Which emulator/s ?

Have you checked your wiring ?

Have you set the audio mixer volume in Retropie ? Can be accessed using one of the front buttons.


#3

The only emulator I have been able to launch yet is the Ports one (Doom, Quake), no sound. GBA emulator detects the roms but when I launch it I get a text saying to configure launch options for emulator/port; no matter what I set here, the emulator does not launch any game and exit. Also the Autocopy files from a USB is not working for me with MAME or Neo Geo (worked with GBA) using the MAME_037b5_romset.

I don’t get any sound effect on Retropie mediabar screen either. I get noise, and the volumen keys are working as I can set the noise louder, but that’s all.

Checked wiring, and the volume audio mixer, which is set to 100. Checked Autio Settings on Retropie, testing every option. I 've set the jak audio cable in both ways.


#4

Hi RAF

If you plug headphones directly into the pi do you get audio through them?

Gee


#5

Hi,

Yeah, I get the same noise than from the speakers.


#6

RAF,

It doesnt sound like your Retropie installation is quite right, if you are using GBA roms they just need placing in the GBA folder as either a .zip file or .gba file.

Dont change the default GBA emulator, ensure you put the GBA BIOS into the BIOS/GBA folder and the GAME into the ROMS\GBA folder. Then restart Retropie via the menu before running the game.

You can browse your Retropie installation via a PC/Laptop by clicking Windows+E (Explorer), then “Network” and then “Retropie” or type “\\RETROPIE” into the explorer bar and then just copy/paste from your PC/Laptop.

Might be worth checking:-

From my testing of Retropie when connected to a Picade then you want the mixer at “44” or “80%” in the Retropie menu (Start > Menu > Sound Settings > System Volume > 80%")

Monkey


#7

Setup quick guide…

Download Retropie image.

Download and install SDFormatter.

Download and install Win32DiskImager.

Format SD card with SDFormatter.

Write Retropie image to SD card with Win32Diskimager.

Put SD card into Raspberry Pi > Turn on Raspberry Pi.

Wait until you have to configure Picade buttons (see attached image) and hold/skip all other buttons.

Select “RetroPie”.

Select “Configure Wifi” > “Connect to Wifi” (unless you are wired) > Select your SSID and enter your wifi password (keyboard required)

Select “Raspberry Pi Configuration Tool”.

Select “Expand Filesystem” and reboot when prompted.

Return to “Retropie” > “Raspberry Pi Confguration Tool”.

Select “Overclock” > “Pi2” (assuming you have a pi2 and want to OC) and reboot when prompted.

Return to “Retropie” > “Raspberry Pi Configuration Tool”.

Select “Advanced Options” > “Overscan” > “Disable” and reboot when prompted.

Return to “Retropie” > “Raspberry Pi Configuration Tool”.

Select “Advanced Options” > “Memory Split” > “512” (you need a keyboard to type 512) and reboot when prompted.

You should now be able to browse your Pi via Wifi from your PC/Laptop and use Windows Explorer to copy/paste your bios/roms into the correct folders.

Hope this helps (if not you, maybe someone else).

Monkey


#8

I really wish my problem is in the Retropie installation, cause is ‘easier’ to fix then. If not, I am in trouble. I installed Retropie with Win32DiskImager, what I didn’t was to format the SD card with SDFormatter. I couldn’t use the Picade on my network because I don’t have right now the option to connect the Raspberry Pi to it (ordered to Amazon a wifi dongle), and I hope that solve my problem copying roms as well.

So I’ll try again soon and let you guys know.

Thank you everyone and great post, Monkey, I am sure it will help everyone newbie around here, should be an Stick Post actually on the forums.

Cheers,

RAF