Has a single person Got X-Hat AND USB Joy/Btn Hat to work together in 2p?

I’ve got an ‘original’ headless Picade from a few years ago. Works fine.

A year ago now I tried to help a mate build a 2p unit. I bought both Picade-X USB-C Main Hat and the USB Extra player Hat (which seems to have miraculously disappeared now from the store EDIT I ‘lie’ you can still get it, it just wasn’t there under Picade search), Pi 4, Looms, the lot from Pimoroni.

Even though I’d done this many times before could I get it working in 2p mode? Nope. It either only see’s the GPIO Hat or the USB Hat, neither at the same time. Best I ever managed, with hacking, was P1 controlled ‘both’ P1/P2 and P2 just controlled P2…so not exactly useful.

I asked Pimoroni for help to replicate/diagnose but, after a while, they stopped responding. I’ve been getting help from an expert and yet it’s still going nowhere. It’s simply one or the other.

I have no doubt I can use Bluetooth controllers etc but, having gone to the expense of building a 2p unit and all the trimmings we expect to obviously be able to use, err, 2p at the same time.

I see, at least one other person having this same issue on here from last yr. Anyone, at all, actually got it working and can show me what they did? Otherwise I’m thinking it’s return time for faulty whatever and useless purchases.

Getting less happy with Pimoroni as time goes on.

DW