Hotkeys / Button mapping issues

Hi guys,

I have purchased and built my very own picade a few days ago. I really had fun with it and it was pretty easy to assemble (although the printed manual was a bit imprecise at some points). All in all i am really happy with the product.

To my question (which is not picade-specific): After firing up, I installed the scripts and configured the PiHAT, which also worked. In Emulation Station you can set a hotkey to e.g. save, exit and so on. Since i used a premade image I installed things on top. But some of the keys aren’t working as intend. For example the button which simulates the ESC key will always exit the game, no matter what i map to it in ES.
I guess there is some override in place which has higher priority than ES button mapping…also my hotkey doesn’t do what it should. But where does this come from? Can it be that the premade image has configured hotkeys in Retroarch which override my settings. How can I disable or change them? Or is it something completely different? Any help is appreciated!

Best, Chris / ch40s

Wow, three days and still no answer. Will try next week, if my assumption was right…

My understanding is this…

When you setup the buttons and joystick in the ES Configure Input wizard, the key that you select for each function is assigned to that function in the Retroarch settings. This is because when you’re playing a game it’s the Retroarch settings that are being used, and ES is not involved at all.

Lots of people have had problems with premade images on the Picade. One solution is to use the standard image on the RetroPie web site. The other solution is to try reconfigure the Retroarch key assignments, which you do as follows. Go to the RetroPie page in ES and select Retroarch. Make sure you’re at the MAIN MENU, then select Settings, then Input, then Hotkey Binds. You’ll then see all the functions that can be actioned by via the hotkey. To change a key you press button A on the Picade, then a box will pop up giving you three seconds to assign a new key. To clear a key press button Y on the Picade.

Okay, got it working. Needed to change the retroarch.cfg in configs/all/ to not use the XHat buttons resulting in the odd behaviour. Then needed to point the emulators to the edited config instead of the system specific ones.