Select & start not bringing up Retroarch menu


#1

Hi

I’ve got the Picade up and running, configured retroarch as far as possible (screen issues etc)… But when im in an emulator I’m unable to use the hotkey shortcuts to get in the retroarch menu this can’t do individual button config got emulators.

Instead it is saying it’s recording video, which I don’t know how to disable… Can’t explain why the other hotkey shortcuts aren’t working. The only shortcut which works (with the wing buttons) is the exit emulator shortcut…

Anyone have any ideas?

Thanks


#2

It’s this problem that prompted me to switch to this control scheme: New Picade - Software configuration issues

[LT] /--------------------------------\ [RT]
           [U]           [B] [Y] [RS]
        [L][D][R]      [A] [X] [LS]
     \--------------------------------/
        [START]             [SELECT]

with LT (Left Trigger) as the hotkey enable since I had trouble with it on SELECT since it kept entering recording mode.

This makes [LT] + [START] exit, and [LT] + [X] go into the emulator config menu, which are both super handy.


#3

Just took a screenshot for later, thanks for that!

I don’t think I configured LS & RS for some reason, I must have thought I wouldn’t need them - forgetting I can use whatever config I want per emulator!

I’ll give this alternative one a go, which looks like it should work, no idea why it’s taking my prompts to record video…
Just whilst we’re here - if I choose to put the Picade in Kid mode or Kiosk mode once all my settings are as I want them permanently, will this prevent the ability to save/access save flies & save states? Just hoping to protect the final settings/config without sacrificing functionality.

Thanks again :)


#4

I didn’t know this was even a feature! You may have to ask this on the RetroPie forums since I don’t know what it is/how it works.


#5

Glad I’ve brought something new to the table ;) I’ll have a look on RP and see how it works!


#6

Thanks for your help with the config, for some reason I can’t get this to work as no matter what I set in the config, whenever I press the left button it just leaves the emulator…

I think the problem here now is the 4 buttons on the front & sides are bound permanently to shortcuts which must be overriding my attempted config… Essentially the left wall button is ‘esc’. The other black buttons must have other permanent functions that retroarch can’t use as none of my hotkey shortcuts don’t work, except fast forward which is personally not have at all but can’t get rid of!

Thanks so far though, this picade has been responsible for me learning more than I ever thought!


#7

Are you directly editing config files, versus using the EmulationStation menus to run the input setup wizard again?.. in fact, are you running EmulationStation at all?


#8

Yea the config was fine in Emulationstation, the issues were only in emulators as the left button kept kicking me out of the emulator (along with a few other unwanted shortcuts)… Seems the short cuts were overriding any of my own settings… I’ve started again now, all fine with the exception of a couple of emulators which still have this issue, n64 and can’t remember what else!

Thanks :)