New Picade owner, initial impressions and questions


#1

Hi folks, another new guy to the Picade scene here. I’m a self-admitted casual tinkerer in the retro and handheld scene (OpenPandora, GPD Win 2 and Retropie user). I’ve no great knowledge on Linux, and have been using premade Retropie images (boo hiss I know!!). For me retro gaming feels more authentic when on a TV rather than a computer screen. I had looked into the prospect of getting a Picade before, but the relative simplicity of the new version won me over. Actually doing the assembly wasn’t as bad as I feared (I didn’t make too many mistakes I think)

Now for the questions! (remeber I am using a prebuilt image so it will cuase a few issues from reading other topics on here already, but it is from a very recent Retropie install image)

  1. I am confused as to whether this version of the Picade has volume control buttons or was that only applicable for the older USB hat version?

  2. I am having trouble configuring my controls in every emulator so far. In the main Emulationstation menus everything works as expected but in any emulator I’ve tried so far, most the buttons don’t seem to work as they should. I’ve tried binding the new inputs in Retroarch and it seems like they’ve saved in there, but when I start an emulator they revert to the ones that don’t? what is the best approach to set all Retroarch settings, or will I have to go into each emulator individually as they have been preconfigured?

  3. Similar to the first question, I am having video problems. I can’t seem to turn off video overlays, they seem to be acting up as they expect a 16:9 screen so cover some of the play screen.

  4. For more complex systems that are best suited with gamepad controls or analogue, is there an easy way to configure an external controller and swap it in and out for control of player 1 as required? Or will the fact I am trying to bind keyboard controls within Retroarch interfere with this plan?

  5. Amiga emulation…I will wait until I have all the other problems before I venture into this. Controller configuration on this seems to be awkward on any Retropie setup!!

I hope someone might help shed some light on these issues (also that there’s a different answer than “you have to create a full image from scratch”)?

Thanks in advance!


#2

I’ll post my updates here as they might be of use to others in the same or similar situations. I’m going to start more with my successes and work backwards, so it won’t exactly match my earlier post in order

I’ve had best luck so far with my video issues, although I will have to go system by system to change the parameters. Removing overlays and setting the screen size to 4:3 seems to have pretty much fixed those problem so far. I did this from retroarch configurations, that will just take some time to get through them all. I would like maybe to try some scanline filters, but I can’t find any so far that would suit a 4:3 720p image.

As for the control issues, this is where things get a bit strange. it seems in my image (I don’t know if this is standard or not), but some of the keyboard bindings duplicate those provided by the Picade controls. Within Retroarch I can change these bindings, then set the bindings for player 1 input to match what I need. I get an error when I try save the auto config for the controls (no immediate remedy for this I can locate on google so far). Just by saving the overall configuration the controls seem to stick ok for some systems (I’ve only tried one or two so far), but on arcade games they revert to the unusable default ones when I exit a game. I’m going to try resetting a configuration completely and setting everything from scratch for a system and see if that helps

The only other remote possibility I can think of for the auto config not saving so far is a possible permissions issue, so I’ll try reset that too and see if that helps

As for anything more than that, I will have to sort out my initial issues before I trying anything extra

If anyone has any tips, let me know!


#3

Hello fellow OpenPandora user ;) <3

I can’t really comment much on the general setup of RetroPie because it still baffles me! As far as I’m aware controls are set by EmulationStation which then overwrites the individual emulator config files. This has always been a bit hit and miss for me because configs that work well in EmulationStation place buttons in weird places in individual emulators. grumble

If you need to alter the keyboard keys used by Picade HAT to aid your configuration and avoid clashes with builtin hard-bindings then you can edit the device tree overlay file. It’s easier than it sounds and basically involves finding every instance of linux,code = <n>; in https://github.com/pimoroni/picade-hat/blob/master/picade.dts and replacing it with the keycode you want to use from here - https://github.com/torvalds/linux/blob/master/include/uapi/linux/input-event-codes.h.

You can then “make && sudo make install” to build and install the new dtoverlay.


#4

Always good to meet a fellow Pandoran in the wild, mine kept me entertained for many years, but doesn’t get much use nowadays as the hinge on the screen cracked so it’s tough to use (but I’m still hopeful the Pyra will continue on in it’s spirit!)

Now for today’s updates, re-configuring each system’s inputs is going pretty well so far. Even though I haven’t found a way away around not being able to save the auto config file, making the changes and saving the overall configuration seems to be solving the issue as a workaround, apart obviously from arcade games. I am getting an error message when I try save a FB Alpha configuration, I’ll have to open the file itself and see if it makes any sense. My other thought is to copy a working configuration into each system folder directly, if that works it would be a lot faster (and I’m making the same changes to each in the first place)

Thanks again for the tips for resetting the actual Picade overlay, but for a guy with terribly limited Linux skills like myself, I’d be afraid of messing up the Picade software completely, I’ll keep on going with my current approach and see how that works out…;)


#5

Made good progress last night, was successful at copying across one working retroarch config file into each system folder, so didn’t have to individually configure each one. I’ve still a few minor issues to sort out, some of the systems are better when not using the suggested retroarch button mapping (C64 and Atari 8bit), as the suggested A button also maps as the space bar so that causes conflicts in some games. A simple rebind of some controls fixes that though. One more tweak I must make is to Amiga controls, the default is picking up the Picade as the wrong input type so that needs to be changed to joystick and it works fine. I think if I change some Amiberry specific launcher files that should be ok (not having great success changing the config files within the emulator so far

I hope these posts will be of use to others when they’re setting up their systems, I couldn’t find that much info so I thought it might be good to detail what I did :)


#6

Still tweaking things to get them up and running properly, made some progress in some areas, none in others! Still haven’t quite figred out the Atari 800 button mappings issue just yet, that’s an awkward machine to use on Retropie on the best of days. As for Amiga, I was advised to uninstall and completely reinstall from source and see if that would help my control issues. It didn’t but strangely it now identifies the Picade in a different name. I must go back on work on the host config file and see if I can get my head around customizing that. My wireless mouse worked without any issue though, so I did enjoy a game of Cannon Fodder to get myself back into the spirit of things

The last thing I did last night was to set up my 8Bitdo SF30 Pro controller. As the Picade is recognised as a keyboard, this makes this the first gamepad on the system so all game and menu controls are handled by both simultaneously. For me this works fine, I was going to use the gamepad mostly for PS1 as that needs more shoulder buttons and analogue sticks so not having to do anything extra to swap between the 2 control methods is ok!

That’s all for now :)


#7

Hi man (I’m french so sorry in advance for my english). The new picade version has no voliume control buttons, so I configure the joystick to controle it and it’s perfect. hotkey + joystick up to increase and joystick down to decrease.

how to do it: options of RetroArch “Settings & Inputs” > “Input Hotkey Binds”, you have “Volume +” and “Volume -”, I choose stick up and down. And then save the configurations in configurations.

for me hotkey is select key


#8

That sounds like an excellent tip, thanks for sharing! :) I’ve not done much with the hotkey binds so far apart from quickly change them to not duplicate the standard Picade inputs


#9

Minor update, rejigging the Amiga host config file was more straightforward than I expected. From the WHDload Amiga group on Facebook I had been told that joy0 was always the keyboard, so it was a simple matter of reorganizing the prioroties in it. I have yet to sort out buttons for menu access and exit game, but we’re getting there!


#10

Thank you for your post Stouffa.
I have the same problem here, pre build image, and i’m okay with some emulators, but others like fba or epsxe are completely wrong by default, with things like quit game on one button and fast forward to another. Can’t save anything but overrides that don’t include controls. How did you solve this one ? by copying a retrorch.cfg working (like genesis) to the arcade / fba directory ?

thx
Dos.


#11

The fast forward button and start movie button were two presassigned on the image I was using, i had to change them to different keys in the hotkey bind section in retroarch settings. You can either do that individually for each emulator (painful) or else copy a working one across to each directory. You can either do it directly on the Pi, or else connect with something like Winscp from your PC. The arcade emulators were the most contrary as i had problems saving updated configurations until i copied over them

As for PS1, i must sort out the aspect ratio on it (defaulting to 16:9 at present) and tidy up the controls on a few others but its almost there! Oh and I’m glad to hear my account is helping others, that’s why i was documenting it. :)


#12

Time for another update - it’s all gone slightly backwards! Not sure what I had changed, but Amiga controls now refuse to set up correctly, even though they were working fine last week. I’ve tried changing the joy0 to both controllers, and changing the mouse settings but to no avail. I even did a full uninstall and reinstall, that didn’t help.

In addition it seems one of my sound settings or drivers may have gotten corrupted, I’m now getting a cannot find mixer error when going in and out of emulators. The image I’m using plays a selection of background music tracks, they still play, but according to the settings, my speaker volume is now at 0. From reading other posts on this topic, I must have changed some setting by mistake

I tried reinstalling the Picade software - no difference. Then I opted up upgrade my entire installation, now it won’t boot up, just goes to a login screen on the terminal window

I think I’ll just reimage the sd card tomorrow and start from scratch! ;)