Hyperpixel 4.0 not working (anymore) with Raspberry Pi Zero WH


Originally using the ‘curl https://get.pimoroni.com/hyperpixel4 | bash’ code worked fine for my Raspberry Pi Zero WH (running Raspberry Pi OS 32 bit) but I’ve run into a problem after I installed python3.

In order to get the PiCameraApp github program to work, I needed to uninstall python and install python3 + image.tk which, after I uninstalled python, the Hyperpixel 4.0 stopped working and I connected my Pi to a monitor via HDMI.

Now that I’m trying to add the HyperPixel 4.0 back onto my Pi to use instead of a HDMI monitor, I’ve run into an issue. I ran the ‘curl https://get.pimoroni.com/hyperpixel4 | bash’ code and all seemed well until the reboot.

As it rebooted the image on the HDMI was the 4:3 rainbow and there was no image on my HyperPixel. I unplugged the Pi from power and when I powered it on again, same issue. Now I cannot get anything to show on either the HDMI monitor or the HyperPixel 4.0 other than that rainbow colour image on the monitor.

Any help would be greatly appreciated