Hyperpixel 4.0 - the *Touch* is NOT working

Hi there,

I’ve installed the latest drivers by following the instructions here https://github.com/pimoroni/hyperpixel4

and while the screen works flawlesly, the touch layer simply does not. Ie screen does not react to any touch.

I’m on Raspbian Jesse and I was previously running the official Rapsi Touch 7" Official Display so not sure if there’s a conflict somewhere? I tried to look up “uninstallation” of 7" drivers but couldn’t find any?

Any help or tips will be appreciated!



I guess this ain’t normal?

$ xinput
Unable to connect to X server

Also I have a file named 99-fbdev.conf on /usr/share/X11/xorg.conf.d/ that has this in it:

Section “Device”
Identifier “touchscreen”
Driver “fbdev”
Option “fbdev” “/dev/fb0”

but as far as I remember this was used by the 7" one :???

Try running this from a terminal window.

curl https://get.pimoroni.com/hyperpixel4 | bash

Thats what I used to install it the first time, yes. No changes.

Ok, the link you posted above , that you said you followed ,has different instructions?

As far as I know, the drivers for the official 7 inch display are included in Raspbian. And it should auto default back to HDMI if the screen is not detected on the DSI port. I have an original version 1 7 inch touch screen connected to a Pi 3B+. I’ve swapped Pi’s in that build, 2B to 3B, 3B to 3B+, and likely going to be a 4B at some point. In most cases I just redid my SD card with a new fresh image.
I don’t own a Hyperpixel though.

I have to ask the obvious, are you sure its the touch version? I ask because there is a non touch version of the Hyperpixel.

Yes its the Touch version one, thanks.

I was just asking just in case I was leaving something back inside any config or any other place with remmants to pointing to the wrong touch device… :? May be it’s a faulty touch panel, I’ll try to swap it with a second unit I have around and report back :?

OK same exact issue with a second brand new panel (TOUCH, 100% sure of it too ;))

Ok, that indicates its a software issue. To me it does anyway. Same SD card used for both displays? If you were running Buster I’d blame it on Buster but you said your running Jessie.
If it was me I’d start all over with a fresh image of Jessie. Do your first boot up and setup with an HDMI screen etc. Then install the hyperpixel and its software and cross your fingers.

The pinout is here

You could go into the Raspberry Pi configuration menu and double check the SPI or something else didn’t get turned on somehow? Make note of what is enabled etc before you change anything. I’m not sure if the hyperpixel install turns them on or off, it uses pretty well every GPIO Pin and sets them to alternate functions.

That’s the 3.5 version tho?

Not sure how this would help mmmmm

I just tried the first touch HP4 in a different Pi3B and different SD and same issue (so must be software related) :?

Jessie, newly downloaded, just in case the one you have is corrupted?

Did the touch ever work on either of these displays?

Ops, here is the 4 pinout, I think its the same as the 3.5, as far as what pin is used for what.

Another obvious question, you’ve removed the protective cover sheet from the display?

Yep, on both.
Ran a DIFFERENT Hp4 on a DIFFERENT pi3B+ on a DIFFERENT SD (on RaspiJessie) and same results.


$ ls /dev/input

Something’s f*cked up here…

Touch is not being loaded on bootup as it seems… (event0)

WHAT is it preventing it? IDK.

I’m lost so its time to call in the big guns

More things I tried just in case:

start with a fresh copy of config.txt and reinstall.

Same results :(

I just got my Hyperpixel 4.0 touch display today. Display works but touch screen does not. Downloaded Buster raspberian full on a new card, loaded it, and installed using :
curl https://get.pimoroni.com/hyperpixel4 | bash

Display instantly worked. Touch is not responsive.

Any ideas?
Where is the documentation?
All I could find was the readme at GitHub.

Same as here:

You could report the issue here

Another option is to go to the main Shop Page, and click the Contact us link at the bottom.
Then put a link to this thread in your e-mail asking for some Pimoroni input.
That link will advise going here and posting your issue on the forum but you’ve all already done that, with no results.

Ended up upgrading to Stretch, oh dear :(

That will work Ok if its not a Pi 4. The Pi 4B will only boot from Buster.
You can get the older version of Raspbian here though.