HyperPixel 4" tutch stopped working


#1

Hi
I have a hyperpixel 4" on a RPi3 and the touch stopped working.
A week ago it worked perfectly fine.
it still shows the desktop background.
Im worried it broke.
Is there another way of telling if its broken?


#2

First off, I don’t own one. But if it was me I think I’d just rerun the one line installer and see what happens.
Then if it still doesn’t work, I’d redo my SD card with a fresh Raspbian install, and run the one line installer for the Hyperpixel one more time. If it still doesn’t work I’d make sure its properly connected to the GPIO and maybe have a look at the ribbon cables on the back side to make sure one hasn’t come lose some how.


#3

Hi
I ran a fresh raspbian install, updated it and ran the one line installer.
And all I get is a big white bloob on the screen.

Even weirder I tried the old software and it worked just fine.


#4

Just to confirm, you have the new 4 inch Hyperpixel right?
And you ran the matching one line installer?
There are two different Hyperpixels and two different installers.
I don’t own either so I probably can’t help you much more than I already have. I have one Pi Foundation touch screen that uses the DSI, and everything else I have uses HDMI.


#5

Hi
Yes I have the hyperpixel 4" Touch screen.
So the one I did yesterday was old raspian (september release) with the right hyperpixel install and did not work.
Earlier today pre-post I probably used the wrong hyperpixel install with the latest raspian (november release).
So I did it again just now with the latest raspian (november release) and the right hyperpixel install and it works.

So I guess I dont have a problem anymore except for why does the touch screen stop working.


#6

Best guess, something got corrupted along the way. Power bump, improper shutdown, etc
Happens to me every now and then, one of my Pi’s won’t boot up or what was working doesn’t want to work anymore. Cheap e-bay etc Micro SD cards can be an issue. Lots of fakes out there that can crap out on you.