Hyperpixel in Kali Linux


#1

I tried to install my new hyperpixel panel on my raspberry 3 running kali linux today.
I used: curl https://get.pimoroni.com/hyperpixel | bash
got a error that i cannot have root access so i made a second account without superuser rights and tried again.
This time i got this error:

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 38282 100 38282 0 0 7547 0 0:00:05 0:00:05 --:–:-- 8391

This script will install everything needed to use
HyperPixel

Always be careful when running scripts and commands copied
from the internet. Ensure they are from a trusted source.

If you want to see what this script does before running it,
you should run: ‘curl https://get.pimoroni.com/hyperpixel

Your operating system is not supported, sorry!


#2

As far as I know that installer is written for Raspbian. Thus the “your OS is not supported” message.


#3

I just tried it in raspberian. There the install ran thru without errors. In the end it asked for a reboot typed y and i just got a black screen.

I had a monitor connected via hdmi to the pi at the same time so i disconnected it but it does not help. Also i tried to disconnect the screen and connect the hdmi again to the big monitor but i did not get a picture back.

I hit shift during boot to get into recovery and deleted the hyperpixel entrys from the config. Now i can see again but how do i get this to work?

Also is it normal that the backlight is constantly on before any drivers are installed?


#4

I don’t personally own one, not yet anyway. I just know that Pimoroni’s installers are written for Raspbian. Just curious, did you use Jessie or Stretch? Did you have anything else connected to the GPIO?


#5

Yes, the backlight has a pull-resistor on its control line so that it’s on by default.

Which version of Raspbian were you using? And which version of the Raspberry Pi?


#6

My raspberry is a model 3 B.
First i had raspberian installed under noobs,
today i tried a clean install of raspberian from a image without noobs, i downloaded the image from the raspberian website (2017-11-29-raspbian-stretch.img) first i used sudo apt-get update, sudo apt-get upgrade and sudo apt-get dist-upgrade until nothing new came in. (Reboots in between) So i used the most recent version of raspberian.

Then i used the command: curl https://get.pimoroni.com/hyperpixel | bash
No errors came, i pressed y for reboot.

The display behaves the same as before with raspberian under noobs installed (no picture, backlicht on) the only difference is
without noobs installed i cannot even delete the hyperpixel entrys from my config to see anything again (with shift pressed in on boot nothing happens). But i can use my windows pc to edit the config on the sd card.

In case it matters here is the content of my config:

For more options and information see

http://rpf.io/configtxt

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode

#hdmi_safe=1

uncomment this if your display has a black border of unused pixels visible

and your display can output without overscan

#disable_overscan=1

uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border

#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

uncomment to force a console size. By default it will be display’s size minus

overscan.

#framebuffer_width=1280
#framebuffer_height=720

uncomment if hdmi display is not detected and composite is being output

#hdmi_force_hotplug=1

uncomment to force a specific HDMI mode (this will force VGA)

#hdmi_group=1
#hdmi_mode=1

uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes

#hdmi_drive=2

uncomment to increase signal to HDMI, if you have interference, blanking, or

no display

#config_hdmi_boost=4

uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

Uncomment some or all of these to enable the optional hardware interfaces

#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

Uncomment this to enable the lirc-rpi module

#dtoverlay=lirc-rpi

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

dtparam=audio=on

HyperPixel LCD Settings

dtoverlay=hyperpixel
overscan_left=0
overscan_right=0
overscan_top=0
overscan_bottom=0
framebuffer_width=800
framebuffer_height=480
enable_dpi_lcd=1
display_default_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x6f016
display_rotate=2
hdmi_timings=800 0 50 20 50 480 1 3 2 3 0 0 0 60 0 32000000 6

Use a basic GPIO backlight driver with on/off support

dtoverlay=hyperpixel-gpio-backlight


#7

How many Amps is your power supply rated for?


#8

I have tried my 2.5 Amp power supply which came in the set with the pi (Vilros Adapter), and a 3 amp power supply i had (Rydges SpeedPower)


#9

Ok, just confirming it was a good capacity to rule it out as an issue. The hyperpixel likely draws a fair bit of current.


#10

I found the error. It was one of the pins, i mesured them all with a meter and one had no connection for whatever reason, visually it looked sound. I replaced it and now it works! Thank you!
I still hope to get it to work in Kali linux, but i am glad it is not broken.


#11

It works in Kali Linux!! So happy!_


#12

Waaah!? How did you have it connected to your Pi?


#13

Just those Pins that are used, do not know the name, seems one was not connected. I cannot really imagine it had no connection, its is metal on metal.