Inky frame 4.0 black screen

Hi All, I was playing with the Inky frame 4.0 and trying to add my own script to the launcher when the screen went black and now nothing happens. When I restart the device (with the inky_frame firmware loaded) the flag LED lights up and stays on but nothing else happens. The screen does not try to display the launcher or do anything else, The buttons on the front don’t appear to do anything (No LED’s light up etc). When I open Thonny there are no files on the Pico W’s file system (This is also the same after applying the latest uf2 file)

I have tried the following all to no avail.
Re-applying the latest firmware (pimoroni-picow_inky_frame-v1.19.16-micropython.uf2).
Running flash_nuke.uf2 to reset it and then applying the above firmware.
Running flash_nuke.uf2 and using the last version of the firmware (v1.19.15).
I have tried running just micropython (rp2-pico-w-20230308-unstable-v1.19.1-941-gdc2186c35) and with this I can get the build in LED on the Pico to switch on and off via software, so the Pico has signs of life.

Short of removing the Pico from the board and replacing it I am at a loss as to what to try so if anyone can help me with ideas to try that would be greatly appreciated.

Thanks in advance

There are instructions on how to do a factory reset here, scroll down to near the end of the tutorial.


Getting Started with Inky Frame (

Thank you, I will give it a try when the page is back up.

I have used the flash_nuke.uf2 from and then pimoroni-picow_inky_frame-v1.19.16-micropython.uf2 and I am getting the same thing. I am guessing that its the same file on the page that was linked above? I will have look at that page when it is available again.

They must be updating that learn article?

Fixed now, apologies for the technical issues :D

Bumpity bump.

I have the same issue (screen is black) and I have tried the same remedial steps (flash_nuke, inky_frame micropython image).

I can communicate with the pico through thonny and run scripts, but executing any of the example files will cause the screen to flash violently between black and white and then settle on black.

The display did work for a time. It had color. It displayed what the told it to.

Using the flash_nuke did clear out the example files on the pico, but flashing the pimoroni-picow_inky_frame-v1.19.18-micropython.uf2 did not bring those back.

Am I hosed?


My issue looks to have been related to the USB hub or cable that it was connected to.
I connected it to another machine (a few days later) and went through the steps again.
Flash nuke
Then manually copying the files from pimoroni-pico/micropython/examples/inky_frame/inkylauncher at main · pimoroni/pimoroni-pico · GitHub to the frame via thonny and after rebooting its working again.
I would say give these steps a try and see what happens.


Hey thanks. I followed your steps. And it works now!

During the process I also set my frame size in, which may have helped.

Thanks again.