Inky Phat isn't updating screen

I’ve tried to run the commands that get installed with the curl script. They run and print output but nothing actually happens on the display.

I’ve soldered all the pins shown on
IC2, Serial, and SPI are all enabled
It’s the latest raspbian image wth an update and upgrade ran

I’m beginning to think the display is fried

Did you solder “all” of the black marked ground pins?

Yes. However, I didn’t realize it needed all of them until after trying to run some commands so maybe that’s what killed it

On the Raspberry Pi itself all the ground pins are linked together. That’s not always possible to do on a Hat or pHat. Plus when its plugged into a PI they all get linked together. That’s assuming all the pins on the header are soldered. I’m pretty sure a missing ground isn’t going to hurt anything. I would be very very surprised if damage was done. There would just be some circuitry that wouldn’t work.
A good picture of your soldering may help?

The square pin is bottom right

I would say that’s your issue. You have some improperly soldered pins there.
Have a look see here.

Well I finally got around to working on it. Some have more solder than they should but I unfortunately don’t have a desoldering pump and the one I ordered off Amazon Prime won’t get here for a few weeks because of the virus. I’m pretty confident all of these are making good connections at this point.

Tested again running and there was still no update on the display
Maybe I don’t have something installed properly software side?

A wet sponge can be used to remove hot solder. A quick tap while the solder is hot will clean it off too. Point the edge of the board down, gpio pins along the bottom. Heat up a pin and then quickly tap it on a hard surface. Put newspaper or something on that surface to catch the solder.
One way to get a good solder joint is to put the tip of your iron against the very bottom of the pin you want to solder. So its touching the pin and the solder pad on the board. They both get hot and the solder flows evenly between the two. If you just heat up the pin things don’t go so well. It’s an acquired skill.
I see a few that don’t look so good. Solder on the pin, but little to no solder on the pad on the board.

While trying to get a temperature sensor to work on the pi (for a different project) I noticed it got hung up on an lsmod. I switched to a different Pi and the screen works fine now

That will work. Sounds like one or more of your soldered pins wasn’t making a good contact on that problematic Pi. Zero’s and Zero W’s are really hard to get these days.
The Zero W with pre soldered header is nice option if you don’t mind paying a little extra for one. Me I like the option of using what ever header I want, female or 90 degree etc.

I promise it wasn’t the solder. Some of the hardware on the pi was fried. It couldn’t even complete an lsmod

Ok, bummer, at least it was only a Zero so not a big loss.