InkyWhat Not working

I have a brand new InkyWhat. I’ve installed the prerequisite software, smbus2, inky, and SPI is enabled. I’ve tried BOTH python and python3.

I’ve tried EVERY example and written my own (just to be sure). I always get this failure:
File “try.py”, line 4, in
inkywhat.show()
File “/usr/local/lib/python3.7/dist-packages/inky/inky.py”, line 345, in show
self._update(buf_a, buf_b, busy_wait=busy_wait)
File “/usr/local/lib/python3.7/dist-packages/inky/inky.py”, line 260, in _update
self.setup()
File “/usr/local/lib/python3.7/dist-packages/inky/inky.py”, line 235, in setup
self._spi_bus.open(0, self.cs_channel)
FileNotFoundError: [Errno 2] No such file or directory

The …/inky.Py file is there, I’m assuming it can’t open SPI for some reason.

“try.py”:
from inky import InkyWHAT
inkywhat = InkyWHAT(‘red’)
inkywhat.set_border(‘red’)
inkywhat.show()

This is on RaspberryPi “Buster”.

Any help would be appreciated.

Usually, when I get an error like that, “No such file or directory” it’s because the interface isn’t enabled. If you enabled SPI via Raspberry Pi Configuration (GUI) try doing it from raspi-config from terminal. It can’t hurt to enable it or double check that its enabled from a second interface. Reboot and try again.

I did the obvious. I said SPI was enabled (disabled and enabled several times to make sure.)

Ok, fair enough. I had a similar issue with a small SPI LCD display and when all was said and done, I wasn’t sure SPI was actually originally enabled like I had thought it was?

Do you know what build or PiOS your running? A new version was just recently released and I believe it uses a new kernel. That may have broken something if that’s the build your running.

VERSION_ID=“10”
VERSION=“10 (buster)”
VERSION_CODENAME=buster

Check the kernel version to see if its, Linux kernel 5.4.51 or Linux kernel 4.19.118.
I don’t know what the terminal command is to do that, I’m a Linux noob if I’m honest.

5.4.51-v7+

I hope this helps. Thanks.

That’s the newest release, as of 2020-05-27. This is just a guess, but I’m thinking that is messing up the inky driver / software.
I’d post an issue on the github page for the inky.


Alternatively you could try and older release.
http://downloads.raspberrypi.org/raspbian/images/