Insert coin in mame


#1

I’ve tried many times to get this working. All I find when googling are snotty people flaming people like me who can not get it working. I’ve had my picade for a year and can not play mame roms. :(

Please help, how the hell do you get insert coin to work??? I have all the latest updates and firm ware for the board. I have my roms in mame-advmame folder and all run. Just can’t insert a coin.


New to Picade
#2

I think your question is answered on these very forums, here: Setting up Retropie - in need of some help please

But since (as I admit in that very thread) I’ve very limited knowledge here, I could be wrong.

Looks like MAME needs to be configured separately, which includes setting up “Insert Coin”, etc.


#3

Yer saw that a while ago when I tried to get it work last time.

Do you know which mame I should be using? I’ve tried roms in mame-mame4all and mam-advmame folders and both do the same.

If I plug a keyboard in the number 5 will do the insert coin. I did not want to start frigging with the default picade key mapping, do you think this is my best option, remap start from x to 5???

Ta. :)

When working I want to install this in the kitchen at work.


#4

And the magic spell to get insert coin to work for mame is, drum roll…

echo b 11 53 >/dev/ttyACM0

This will map the ‘5’ number button above r and t on your keyboard to the left most button on the front panel. I have the latest firmware so that the changes should stick after rebooting.

Wasted so much time trying to config mame…


#5

And if you want the right button on the front panel be start…

echo b 10 50 >/dev/ttyACM0

Wow, feel like harry potter. Two new spells in one evening.


#6

You can do the same thing without code and will be better in the long run since you’ll be able to remap buttons for specific roms - This will work in all non-LibRetro (lr-xxxx) emulators.

Paraphrasing because I’m not in front of my Picade…

Launch Mame and then any Mame game with a USB keyboard attached
Hit TAB
Select Change Settings (all games)
Scroll down to UI Cancel and set to ESC by pressing Enter on the keyboard and then the ESC key on the Picade
Do the same for UI Confirm - set to Enter on the Picade
Player 1 Coin map to C
Player 1 Start map to S

Also do the Joystick directions and set the buttons how you want…