Joystick pulling to the left

#1

I have an issue where my joystick pulls to the left in games and in the retropie menu.

It’s a fresh build running the appropriate hat drivers and it’s driving me crazy?

Can anyone help. I’ve tried reconfiguring inputs numerous times and even tried a preconfigured image with the hat driver added and the picade joystick calibrated the same as my own build. Still drifting. Sometimes in the system and games menus the left input kicks in and I get random scrolling through systems and games.

#2

Have you checked the hardware- is the left microswitch sticking? You could buzz it with a multimeter in continuity if unsure.

#3

Pimoroni are sending me a new joystick. I still think that maybe this is a software conflict of some kind though as I built my brother his 10 inch picade yesterday and he is having random issues too with ghost inputs.

I’ve even purchased 2 different new power supplies, a genuine pi3 one and a 3rd party one rebuilt an image again and again (tiresome) and still the same.