Keybow mini not working

I’ve followed all the instructions, but I still can’t get the keybow mini to work.

It shows up in Windows device manager as unknown device

I format the SD card as fat32 I’ve copied the files from the zip on to the card and plugged it in no lights nothing. This is a new zeroWh. I’ve tried plugging it into USB 2 and USB 3 I still do not get anything out of it please help.

You copied the contents of the SD card folder, not the folder right?
Also make sure you have your USB cable plugged into the DATA port on the Pi Zero, not the power port.

Just plugged in a HDMI cable to a TV nothing comes up at all. I have tried with and without a separate power supply.

Yes I use the right USB port and I copied the contents of the folders into the root of the SD card if I try a raspbian image the pi zero boots up fine

I don’t own a Keybow, just so you know. This is what is on the setup tutorial.

  • Did you definitely format your micro-SD card with a single FAT32 partition?
  • Make sure that the files on the SD card aren’t inside a folder
  • Make sure that you copied all of the files across from the unzipped folder
  • Is the micro-SD card plugged in fully, and is the micro-USB cable plugged in fully?
  • Is the Keybow PCB pushed onto the Pi’s pins as far as it will go?
  • Is the green activity LED blinking on your Pi Zero WH? If not, then it should be!
  • Try a different micro-SD card, if you have one
  • Remove the baseplate (you won’t need to do this on Keybow MINI), and plug a mini HDMI cable in. When you plug the power into the Pi Zero WH, you should see a bunch of text appearing on the screen.

So to recap this is what I have tried thus far
4 different Pi Zero’s including a brand new one delivered today
3 different microSD cards (of varying sizes)
3 different USB cables
2 different computers (Windows 10 pro and Windows 10 Home)

In all instances, if I use Raspbian image - the Pi’s boot up fine to the desktop
However - with the Keybow software no activity lights, nothing out of the HDMI
I do get an item in the Windows device manager, however:

Annotation%202019-09-01%20150245

1 Like

Now don’t I feel sheepish! That’s worked. it now shows as a keybow in Windows and the key lights work.

014014 <- keybow

Ah, nice to hear you sorted yours out as well. It kind of sounded like you might have done what he did. It was easier to just link to the other thread than to hash it out all over again. Have fun. =)

1 Like

[quote=“alphanumeric, post:7, topic:11505”]I had copied the whole downloaded keybow firmware zip contents to my sdcard rather than just the contents of the sdcard folder. Doh!
[/quote]

This has got to be a common mistake and I think the whole Keybow SDCARD distribution should be built and uploaded as a standalone zip that just has the SD Card stuff.

Edit: Raised as an issue for when I have a moment - https://github.com/pimoroni/keybow-firmware/issues/37

1 Like