Keybow Problems

Hi all,

Recently lost the use of my right hand (severed radial nerve). I work in IT, mostly in the terminal! continuously pressing various key commands and thought the keybow would be an excellent aid while my hand is out of action.

I struggle at the moment with certain key combinations involving alt or control, or pressing right shift and using the scroll wheel for zooming. So I thought I’d map out these keys onto a separate peripheral to avoid my hand splatting over multiple keys and accidentally hitting enter.

I formatted an 8G SD card I’ve previously used in a RPi3. Copied over the Keybow files from the instructions and fired up the Pi Zero.

No lights on either the Pi or the key switches. Windows detects the device as a “BCM2708 Boot” but doesn’t want to do anything else with it.

I’ve tried formatting and repeating the procedure with another 64GB card, swapping USB ports, directly on computer, through a passive hub and also through a powered hub and no luck.

Have I missed anything?

Formatted as Fat 32?
And copied the “contents” of the keybow folder to the card, not the folder itself?

Yep, formated as FAT32 using the SD card formatter application. Then extracted the contents of the keybow folder into the root of the SD card (not the folder itself)

Did you do the troubleshooting bits from here?

If you had plugged into the wrong USB Jack on the Pi it wouldn’t have been detected. It needs to be connected via the data port, just for the record. Not the power port.

It sounds like an OS issue? Maybe a corrupted download? Just for the record, I don’t own a keybow. I have tinkered with gadget mode though, its been a while since I did that though.

Yes, followed all the steps except for hooking it up to a display as I don’t have a mini-HDMI cable/converter.

The USB cable is plugged into to port that’s more easily acceptable (right hand side with cutout underneath). Presumably I don’t need an additional power input too?! Is that the bit I’ve missed? Or can it be all powered through the data port?

It can be back powered via the data port. It was designed that way on purpose for gadget mode. The Data port is the one closer to the HDMI port, between the HDMI and the other Micro USB port. The one closest to the edge of the board is power only. Have a look at the picture here

I can confirm that’s the port it’s plugged into.

Yeah, you said it was detected, but it doesn’t hurt to double check things. The PC won’t see it if you use the wrong port. The Micro USB power port doesn’t have the Data lines connected.
If you haven’t already, I’d re download the kebow software and do up a fresh SD card. Maybe a different SD card.

Tried a few different things and finally got it booting using a different USB cable. I found a mini-HDMI lead too see what was being echoed to screen. Turns out I might have same iusue as another poster: Keybow not working

It does light up though. I’ve also used a different png pattern and that’s loaded fine.

However, Windows doesn’t recognise the device :(

Wish I could be more help, from looking at the other thread you linked to Sandy @sandyjmacdonald is the guy to talk to. You could send him a PM with a link to this thread to speed things up.