Kivy with Rapsberry official touchscreen


Hi everyone,

I am looking forward to using my raspberry pi 3 with my official touchscreen to control some stuff in my house.
The problem is that when I launch the kivy program and start using it with my fingers to click on buttons for example, it actually clicks in the app but it also click in the raspbian desktop. It makes me launch other apps :(
What shall I do to make the app on the true foreground and avoid clicks in the background/desktop etc. with the touchscreen ?

Thx in advance !


You have a couple of avenues open for a possible solution. If this is the only thing you are using your Pi 3 for you can turn off the Raspbian desktop and start up the kivy app as a full screen app. When run from the command line w/o X a kivy app will automatically start up full screen.

The other thing you should check is your .kivy/config.ini file. In the Input section make sure you don’t have extra entries for the mouse.