"LTR559 not found" on WeatherHAT with Pi Zero

I am trying to get a weather hat working with a Pi Zero using the example scripts.
With the scripts that initialise the sensors, I get:
RuntimeError: LTR559 not found

Several posts seemed to suggest that when they switched boards, this then worked. - but is there a way to test if the sensor is faulty independent of this error message? Or is there anything on the software side I might try?

Many thanks,

Which, example? You may have to edit the file so its using the correct i2c pins.

I tried a few examples. brief.py, weather.py and BME280.py.

Is there some guidance on setting the i2c pins for the pi zero? Looking through the getting started with the weather hat page, I assumed that it would be set up for the pi zero by default?

Many thanks,

Ops, sorry, I was thinking Pico when I posted, not Raspberry Pi.

On Pi there is only the one i2c so your code should “just work”? Did you solder the headers on the Pi? If yes, post a picture of it if you can.

Have you tried running
sudo i2cdetect -y 1

Below is an image of the soldered header - I think this looks ok.

Also, an image of the output from the i2cdetect call - I have not used this before so not sure what I am looking for to diagnose the issue.

Many thanks.

Soldering looks good, that i2cdetect output doesn’t though?
i2cdetect will show what i2c devices are on that bus.
All that should be there are for that hat are
BME280 temperature, pressure, humidity sensor, @ 0x76
LTR-559 light and proximity sensor, @ 0x23
and the Nuvoton MS51 microcontroller, @ 0x18 << I think?

I would remove the Hat and reseat it on the Pi, then run it again.

When I run without the hat on - all the entries are: - -
When I replace the hat and reboot I get similar to above but with more entries filled in - see below.

I think I have another Pi zero somewhere. Maybe I’ll switch the sd card into there and see if I get the same behaviour?

All – is normal with no devices connected / detected. Something is messed up on the Hat?
The pins to look at are
GPIO 2, Pin 3, SDA
GPIO 3, Pin 5, SCL