Microbit v2 529 error code

just received a microbit v2 on power up it displayed error code 529.

Tried to reflash firmware with no luck.

It seems to be stuck in bootloader mode.

The micro:bit has detected an incompatible image. This can occur when you If you attempt to use an old .hex file with the latest micro:bit. Try updating the hex file in the editor in which it was created and downloading it again.

thanks for your reply.

The microbit is stuck on code 529, and the reset button does not clear it.
It was like that out of the box, and did not do any of the outofthebox display, advertised in leaflet that came with it.

Mu editor tell me there is no microbit connected, tried to pair with ios and did not work.

Tried i on windows and mac with no success.

I m getting to the point of giving everything up, lately nothing seems to work fo me.

I have been happy messing about with my hobby, I came from a Electronic and IT background and carried on in my retirement years.

Thanks for your help.


Don’t let a setback stop you, it happens. It’s been a while since I have used one of my Micro-bits, will have to clear the cob webs on that info in the old brain.

No I wouldn’t expect it to have an error from the get go. They do come with a demo file stored on them, my original version 1’s did. Maybe yours got a bad flash or something.

I use mine with Mu as I like to use Python. I just plugged mine in with Mu open and it detected it. Make sure you have a data cable not just a charging cable.

If you hold down the reset button, while plugging in the USB cable it should show up as a drive in file explorer. Mine has AUTO_RST.CFG, DETAILS.TXT and HELP_FAQ.HTM on it. I had put the original demo file back on it just before storing it away.
I’m doing this all on my Windows 10 PC.

Introduction | micro:bit (microbit.org)

EDIT: Found this right after posting.
Erase multiple micro:bits : Help & Support (microbit.org)

Retired Electronic Technician here, this is also my hobby. I tinker with Raspberry Pi and Pi PICO mostly. Arduino now and then, and at one time BBC Micro Bits.


Thanks for your help, will give it a go.

I also have all the raspberry pi from 0 to 4, most of the arduino board and the old flotilla set up, and the pico.
I have a flight aware aircraft set up set up using a zero w which is on all the time.
Also interested in radio data decoding i.e sstv morse and rtty.

You need to excuse me if I make spelling mistakes as English is my second Language.

Will let you know if your links help

Thanks again

Don’t worry about spelling, English is my primary language and I make my fair share of spelling mistakes.
There is always going to be head scratching, trust me, been there done that multiple times. Lots of fun and satisfaction too, when you figure it out. =)

The microbit was already showing error 529 when first powered up, nothing showed up as described from the leaflet that came with it.

Mu does not see the microbit.
I personally think is a bad flashed unit, and there is no way of resetting it, it flashes the error code all the time.

When connected it does show the drive.


Try this,
plug in the USB cable.
Then drag and drop that erase hex file in the link above to it in file explorer.

EDIT: Worked for me by just plugging it in, didn’t have to hold the reset.
It shows up as MICROBIT. Once I dropped the erase file on it the demo stopped.
Then I dropped the original demo file back onto it and it went back into the First experience demo again.

If I hold the reset it and plug it in shows up as MIANTENANCE. Not sure what that means or is for?

Set up | micro:bit (microbit.org)

Out of box experience | micro:bit (microbit.org)

Good Morning

I followed yor instruction with no success.
The unit v2 of microbit will not perform anything at all apart from displaying the error code.It will always appears in Maintenance mode.

I have sent an email to Pimoroni requesting a new one and will send the faulty one back.

I hope they will send another one.

Will keep you posted

Thank you


Pimoroni agreed to send another one, i will post the faulty one to them.

will keep you posted



I have received the new one and everything is working fine, even managed to pair it with my ipad.

Next step will be using with Mu.

Once again thanks for your help.

Nice, now you can have some fun with your new tech. =)