Mini Starter Kit Delivery


#1

Woohoo! I just got my Mini Starter Kit through the door and it’s amazing! The packaging and everything look/function great - HOWEVER : ) it does look like the ‘Getting Started Guide’ and the ‘Recipe Cards’ were missing. I don’t know if there are PDF versions of these anywhere for me to print off - or a Getting Started page somewhere? Cheers!


#2

Don’t worry, you’re not missing out on anything. The software and process for “Getting Started” are still very much in flux, so we haven’t produced a printed guide yet- it would be outdated pretty quickly!

Right now the best place to get started is here: http://flotil.la/start/

You currently need Raspbian Jessie, but I’m putting together a Wheezy-compatible version today and we’ll eventually replace this with a grown-up install process that uses apt-get.

As for Recipe Cards, they’ll be superseded by Cookbook, but we’ll have some printed ones on the way. We’ll pop some out in an envelope to anyone who has their kit already and wants the cards.


#3

That’s great - thank you very much - it’s such a great system and I can’t wait to use it (and get more parts!)

Cheers,
Jaison


#4

Got my mini starter kit yesterday and tried it out tonight: it was looking working fine, but has now stopped :-(
Before starting I downloaded rockpool to my Pi 2 (Jessie) as per the instructions, connected it all up, and the dock and attachments were all recognised and working.
However the power supply to the dock seemed a little flaky and would reset if I moved it slightly. Now when I plug it in I get the top 3 lights scanning for a second, but then all turn off and the dock is not recognised. Any ideas what I can try? (Thanks in advance.)


#5

Ruh roh! That sounds a lot like a bad USB cable- do you have an alternate microUSB cable to try it with?


#6

Thanks for the reply - yep it does look like a dodgy USB cable, but I’ve tried a couple of other USB cables that I know are OK, and the dock is still behaving in the same way as before (3 lights scanning for a second or so, then no lights at all)… are there any other checks I can do? (I’m going to try a fresh Jessie image tonight, see if that makes any difference). Cheers.


#7

There is one thing you can try. Updating the Flotilla firmware. If you want to give that a go, I can write up instructions ( or possibly a magic updater script ) for you to try; I wont publish them publicly yet though since I don’t want anyone else to try it ( yet ).

Honestly, though, if it’s not the cable then it sounds like you might have a marginal USB port that worked long enough to pass our testing and then failed. It’s definitely possible!


#8

Sounds like a plan - I’ll give the firmware update a try. If all else fails I guess I’ll have to send it back to be checked out. Thanks again for the quick reply!


#9

OK, no joy with the fresh Jessie image - the dock is still not being recognised by the Pi (3 lights scanning for a second or so on the dock when connected, then no lights at all). If I want to send it back for you to check, what’s the process - should I do it from the Kickstarter portal? Thanks!


#10

Hi, looks like I have a similar problem.
Jessie is installed and updated
tried various USB cables
connected a powered USB hub in-between
and still rockpool looks in vain.
libboost installed
anybody have any other ideas


#11

see this topic: Connecting - error while loading shared libraries: libboost_filesystem.so.1.50.0


#12

I reinstalled Jessie and then ran the script

curl -sS get.pimoroni.com/rockpool | bash

and that solved the problem
Thanks