Missing v 1.18.0 on Pimoronipico Git Page

Hi Gadgetoid,

The latest version 1.18.0 of Pimoroni Micropython from here unfortunately is a faulty link and gives a 404. I’m hoping that installing this rather than generic micropython will allow my pico/breakout garden/BMP280 to chat happily. At the moment I’m struggling to get any of the examples to work because of smbus issues.

The missing link:



This what your looking for?
Release Version 1.18.0 · pimoroni/pimoroni-pico (github.com)

EDIT: Ops, looks like that’s the broken link, should have tried it before posting. My bad.

@gadgetoid @hel

Try this instead.

Thanks Kerry,

Thant’s what I was after.


I grabbed a copy for myself too. Looks like there is a typo in the download link.

Oops, I think some copypasta errors must have snuck in there - thanks for the detective work @alphanumeric !

I’ve fixed the links :)

1 Like

Shouldn’t it be
pimoroni-pico-v0.3.3-micropython-v1.18.uf2 ?
The actual file name I mean?
The link works now, the file name doesn’t seem right though, compared to what its replacing.