More and more Control problems

Hi folks,

I recently finished my Picade and tried first to install latest version of Retropie on one new SD-card. The buttons and joystick was never identified as “Keybord” in Emulation station after the online installation of drivers OR which ever step from advices in forums that I took and therefore it could never be configured.

I formatted and made a new fresh installation on the same SD but with the same result.
I bought a new SD and made a fresh installation on this with exactly the same result.
I now downloaded the update from Github and made at local installation and… tada! All the controls were now possible to configure in the Emulation station!


Starting the first ROMs in mame, the joystick and buttons are no responsive! When i try to configure the control in mame, it seems that that all inputs are right pre configured though I can’t reconfigure them.

Maby it’s a problem that could be adressed the Liberto Mame I thought


unfortunally not, as I now tried NES ROMs as well and the controls doesn’t work there either.

PLEASE! Give me some ideas or advice what to do???

AND - Why are all theese problems? All people buying the Picadehat and RPI3B+ (as in my case) installing the latest Retropie should get the same problems as me, right?? But this doesn’t seem to be the case?

Did you run the curl command to install the drivers?

curl | bash

If you are booting into Retropie then hook up a keyboard and hit F4 to take you to the command line so you can issue the curl command, reboot and you should be good to go …

I did actually run the curl command to install The drivers in all my tries without any luck.

But I can tell that trying to reinstall in the same way again for the 5th OR 6th time, suddenly it actually worked out. It is hard to tell why as I followed exactly The same procedure as all The other times.

For all of you having The same problems as I, the solution unfortunally seems to be to try making a fresh install again and again and again… Finally you might be lucky.

often a microSD canbe the problem if you follow the same process repeatedly with different results. I watch the formatting pattern (speed which it formats and if there are any hesitations in the formatting).
you want a smooth consistant format, and if it fails to do such or hesitates at a certain percentage or randomly its not really a good microSD for an operating systems as it may just be corrupting data that is being written.
some of the unknown counterfeit sandisks I have received from ebay have these issues.