Mote strips connected to pHAT not working as expected


#1

I finally got my Mote pHAT/HomeKit setup working, but the experience is marred a bit by the LEDs not doing what I tell them to.

First, they’re flickering almost every time I change their color: https://i.peterwunder.de/motephat.mp4
All I’m doing in this video is slowly sliding the Home app’s brightness slider up and down, but the flickering happens on complete color changes too. Is this a known problem with the Mote pHAT?

Secondly, the LEDs update one after the other, starting at the Mote strips’ USB port, which ruins the illusion of having a true LED “strip” instead of one made up of several LEDs. I don’t remember having had this problem with the Mote Host. Is the Mote pHAT just “slower” or

Thirdly, look at this: https://i.peterwunder.de/motephat_half.jpg
This sometimes happens after doing

motephat.set_all(stuff)
motephat.show()

quickly, twice in a row.
Other than implementing a cooldown timer of about a second, what can I do to avoid this?

And finally: Are the maximum brightness levels of the Mote pHAT and the Mote Host different?


#2

I think 1 and 2 are somehow related, but I’m not entirely sure what would be causing it. What model of Raspberry Pi and OS are you using? Could you have made any changes which might affect the SPI speed- the symptoms you describe sound like the data is being clocked out really, really, really slowly which I could only imagine is caused by some weird configuration on the Pi.

Have you tried a fresh Raspbian Jessie image to eliminate that possibility?


#3

I’m using a Raspberry Pi Zero W V1.1 that I solely got to power the Mote strips. I installed Raspbian Jessie just a few days ago but other than updating/upgrading it didn’t do anything with it before now.

I’ll try reinstalling Raspbian tomorrow. Hopefully that’ll help.


#4

Interesting, have you connected the Zero W to WiFi at all? Is it otherwise functioning as expected?


#5

First off, sorry for the massive delay. I forgot to pull some important stuff off the microSD card before wiping it and had to get it back which took me a few days.

Yes, the Pi Zero W is connected to WiFi. I guess everything works as expected, but this is all I have done with it so far.
Additionally, reinstalling the OS didn’t help. I haven’t been able to reproduce that half/half colored LEDs thing yet, but the strip updates are still slow.

Edit: You mentioned SPI speeds in an earlier post. Is there a way to increase said speeds?
Or, as a last resort, would it help to use a different Raspberry Pi altogether?

Another edit: All these problems go away when I use the Mote Host instead of the pHAT.
This is kind of disappointing since this means that I’ll have to connect yet another USB cable so that the strips use their full brightness.


#6

One last video because I literally just noticed the bash oneliner
curl https://get.pimoroni.com/motephat | bash
on the mote-phat GitHub page. Hoping that it would alleviate the problems, I ran it and tried the rainbow example it installed (~/Pimoroni/motephat/examples/rainbow.py):

…well.
At this point, I have given up on my project. Since the Pi Zero’s intended place doesn’t have another power supply for the Mote Host and the Mote pHAT straight up isn’t working, it’s impossible to complete. :/