Mote unresponsive


#1

Hi, I finally got around to unwrapping my Mote. Installed software as per Getting Started instructions. But nothing happens. Should there be a power indicator light on the controller board? Nothing lights up.
I’ve tried copying the code from the Getting Started web page and I get an error “No module named mote”.
I’ve also tried running the test.py code but absolutely nothing happens - not even a flicker of light…zip.
I’ve got a power cable connected but nothing lights up at all. I don’t think even I could mess up the connections here so… …what else might I have done wrong?

Thanks
Sue


#2

on what operating system is this?

… but otherwise, yes, when you plug in the Mote host an init sequence should flash all the connected sticks one after the other. If that is not happening it might be a faulty cable (or host PCB, or stick).


#3

The initial light sequence happened when it was first plugged in but not since - I guess this should happen each time the Mote is turned on?
I don’t need to power the Mote separately?
It’s on Raspberry Pi Jessie.

Cheers
Sue


#4

Just turned the Pi+Mote back on…
Mote light strip 1 red light 1 flashed
Then all the light strips flashed
Opened the test.py file from the examples folder - nothing, not a peep. No error message, just no response.
Tried rainbow.py - same again. No error but no response.

Sue


#5

how may Mote sticks do you have? maybe they are drawing too much power - what PSU do you have?

incidentally what Pi do you have, you can run the following to identify the board if you are unsure:

curl https://get.pimoroni.com/diagnostic | bash

#6

Had all four attached.
Took out three, leaving just no.1 - nothing
Diagnostic = Raspbian Jessie, Pi 2 B Rev1.1
Power to Pi is standard micro USB and have same to Mote

Have tried running test.py again with still same result. No error but no response
Sue


#7

I am not sure I’m picturing your setup. Your Mote is connected to one of the USB port on the Pi right? What about the Pi itself, how is it powered up, using an official Raspberry Pi Foundation power supply, or something else?

Also, can you post yhe entire output from the diagnostic, it contains additional info that will allow me to assess whether it could be a power issue more easily.


#8

Mote is connected to Pi via red cable to USB. I’ve got Pi output going to a Motorola lapdock which is currently charging. I’ve got the lapdock in one USB on the Pi and a wifi dongle in another USB on the Pi, leaving two USB ports free. I’ve tried the Mote in both available ports.

Pi is powered by official Pi power cable.
Mote is powered by another official Pi power cable.
Full diagnostic below

pi@raspberrypi ~ $ curl https://get.pimoroni.com/diagnostic | bash
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 12996 100 12996 0 0 53476 0 --:–:-- --:–:-- --:–:-- 53702

Raspbian GNU/Linux 8 (jessie)
Linux kernel 4.4.34-v7+ on armv7l
Revision match: Pi 2 Model B Rev 1.1

card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]

Devices on Linux Foundation 2.0 root hub
Bus 001 Device 009: ID 1241:0003 Belkin
Bus 001 Device 008: ID 22b8:0938 Motorola PCS
Bus 001 Device 007: ID 0424:2517 Standard Microsystems Corp. Hub
Bus 001 Device 006: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 005: ID 16d0:08c4 MCS
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Estimated MaxPower 100mA +100mA450mA500mA 0mA
Max USB current setting is active

I2C appears to be enabled
i2c_dev and i2c_bcm2708 loaded

I2C devices detected:


#9

While I can’t be sure the issue is power related, the maximum current draw over USB is limited to 1200mA and you’ve got it pretty much maxed out according to the diagnostic.

… granted that if you are poweting up the More independently that should alleviate much of the concern, the serial communication occurs over USB and that could be what is failing right now.

I encourage you to try with a simplified setup that minimises the power draw over USB. Once you know the Mote hardware works then you can try to re-add peripherals and see if you can pinpoint where it tips to failure.

It could also be something as basic as the cable you are using to connect Mote to the Pi, so it is worth trying a few different ones. And if you can’t get Mote to work even with a setup stripped to the minimum then, I guess it’s possible it is DOA although the boot sequence is exactly as expected so I’d say it’s the least likely scenario.


#10

I’ve currently got just one Mote strip connected to port 1 and I’ve changed the red cable (that came with) for another cable that I know definitely works. Lapdock is fully charged and powers itself. Pi has it’s own power cable as does the Mote so each piece of hardware is independently powered, none of them are drawing from each other.
Turned on Mote this morning and the single strip flashed a single red LED then all the LEDs flashed. Tried test.py still nothing.
Shutdown Pi and as I turned off power the single Mote strip flashed. Turned it all back on but Mote strip didn’t flash. I’ve moved Mote strip to each of the other ports on Mote - still nothing.
The set-up is so simple I’m not sure where I could have gone wrong.
I’m running out of ‘free’ time but if I get a chance I’ll try putting my SD card (as it’s got all the Mote software ) in a different Pi; that’s pretty much all I can think of to try.

Cheers
Sue


#11

So, I finally got back to the Mote issue. I re-installed and downloaded using instructions on Yarr-niversity and this time all (seems) to be ok now. I’ve got a single strip of LEDs currently connected and they are rainbowing away. I think the issue was that I got a folder called Pimoroni where everything seems to have gone previously, but today I found a separate folder just called mote and the examples in there seem to be running fine. Another case of “operator error” I think.
Cheers for the help
Sue