My Pi won't drive my TV anymore


#1

HI,

My wife bought me a Pi B+ for Christmas and I set it up using my fairly old Pioneer plasma TV in the front room, then subsequently I’ve only used SSH as it’s only been a VPN server so far.

Now I want to use it to play video files, but now it won’t show any output on the Pioneer TV or another LCD TV. I know it’s booting because I can SSH into it and also if I switch the HDMI cable into yet another TV or a DVI monitor the picture is there, although with yet another monitor which used to work, it doesn’t work now. So it used to work but no more.

I have tried:

  • 3 TVs and 2 monitors.
  • 2 HDMI cables
  • 3 PSUs
  • 2 MicroSD cards
  • my original Raspbian installation, plus newly downloaded OpenElec, BerryBoot, latest NOOBS.
  • more variations of settings in /boot/config.txt than I care to recall

One more thing - when I execute tvservice -m DMT or CEA I get exactly the same output whatever TV I’m plugged into (rebooting between). Then I did it again late last night and got a completely different set or results than before, but again the same from all TVs. Ditto reading the edid data.

So is it busted or is there something else I can try ? I’ve tried so many combination and I can’t see a common point of failure, except the board itself has failed somehow.

Tim