Raspberry pi 2 blank TV and two lights


#1

I’ve been lucky enough to spend two weeks at pimoroni on work experience, and I’ll miss everyone there now it’s over :( Hopefully there’ll be an opportunity in the future for me to go back again sometime!
On top of putting up with me for two weeks, they gave me a bag filled with things to tinker around with, including a unicorn hat, displayotron hat, explorer pro hat, pibow, scroll phat, ninja solder, and a tin of components and proto boards from gee! They even gave me a raspberry pi 2 and pibow coupé!! I am a very happy person :) :) :) .
I’m just having a problem with getting the pi 2 to connect to my TV. I plug everything into the pi except power, turn on the TV and then plug the power in. I get two little lights - one green and one red, but nothing on the TV. I tried my old pi (model B 1st gen) doing everything in exactly the same order and it worked fine. I’m trying to use the card from the old pi on the new one, and I’ve tried downloading noobs onto a different SD card and using that but it doesn’t make a difference. I’ve also tried plugging the pi in AV and using different HDMI leads and sockets but nothing I’ve tried works. Does anyone know what I could try?
Any ideas are great!


#2

What power pack are you using? The RPi2 needs more juice.

Do you have a different TV or monitor to test it on? Pop around a mates?

May be worthwhile to go over to the official forums. Some peeps over there really know their stuff.


#3

I’ve tried on on a different tv and it still doesn’t work :( The power pack is one I used for my raspberry pi b 1st gen.


#4

It is possible that the RPi does not like your SD card. Are you connecting to you network with a wired connection? If so then check your router to see if you can see it. It may be trying to boot hence the lights flashing but not getting very far, I’ve had this before when I did not set up an SD card correctly.

The other thing is that as soon as the RPi starts to do the display it brown outs because your power supply is too weak. Do you know the output? The foundation recommends 1.8 amp.


#5

Ok, I got it working. I formatted the card and downloaded noobs again. Turns out I had a very old version of raspbian on that card that the pi 2 didn’t seem to like. I can’t believe how fast the 2 is! It starts up in about 5 seconds and loads applications almost instantly. This new version of raspbian is also a lot nicer. It feels more like a current operating system than the old one, which was a bit clunky.
The only issue I’m having now is that the rainbow square keeps coming up in the corner of the screen which I believe means there isn’t enough power. I checked the rating of my power pack and it says output = 2A which should easily power the pi 2 which requires 1.8A. Think it must be a problem with my USB lead so I’ll try a different one, maybe one that’s slightly shorter. Shame, I like my bright green usb it goes with the blue hdmi ;)


#6

Nice one, I did not know about the rainbow square. Nice to know it’s working. Happy tinkering. :)


#7

yeah, USB cables often cause some misery… I like the convenience of flat cables, but it’s a no-go for my Pi2 but for example OK for headless A+.