Naturewatch camera kit


#1

Green led flashes then becomes solid, red led on cable solid but no wyfi detected by phone or wyfi analiser app. Any ideas


#2

Reloaded disc image but this time did not change the default name or password and it worked!
So sensitive to renaming config file. However, i could not see any difference except the length of the words used?? For the moment I am content to use the default data.


#3

What program did you use to edit the file? If it was notepad on Windows give notepad++ a try. I’ve read that Windows notepad can render the files incompatible somehow.

https://notepad-plus-plus.org


#4

Yes it was indeed notepad so thanks, I will try notepad++


#5

Hi, newbie here!

Naturewatch acknowledge problem with changing their config file in windows. Documentation and FAQs have had this added with news that they expect a fix next week. In the meantime they say reload the disk image onto microSD card and use config file as is.

They state that if the config file reads out as one line there will be problems! (Wonder if they used a mac?

Don’t laugh but my camera has upside down pictures…


#6

I’ve also got upside down pictures. Not too much of a problem though as I haven’t decided on a container or how to mount it yet. I did however have a look at the code on github and it does mention screen rotation, unfortunately my coding skills are pretty low so I couldn’t figure out how to activate it.

In the end I bodged it a bit and just added self.camera.rotation = 180 under the resolution part near the top of the code. Seems to work ok but it would be nice to know how to do it properly. Obviously though I’m no expert so try that at your own risk as it may create headaches further down the line.


#7

I just built one. Got it running, photos good. Then connection got iffy. Then photos appeared upside down. Then worst of all, green light went out an now – NOTHING!

BTW, total newbie to Pi.

Any advice welcomed. Ive already e-mailed this Co. but out out of hours so trying the Forum.

regards


#8

Do you have another power source you can try with it? If not can you check the power source with something else?


#9

Thanks, but I’ve tried several known good power sources.


#10

If the power is good then I’d try the SD card next. If there isn’t a valid card in the slot I don’t think the green light will come on. Rewriting the card or trying a different one may help.

The advice I’ve always read has been that you should always shut down your Raspberry Pi to avoid card corruption. Strangely though no easy option has been provided with the Naturewatch software, their FAQ even says that it’s not a problem.


#11

Thanks. I’ll try that next.


#12

I crash and brown out (abruptly shut down by accidentally shorting the power supply to ground) my Pi’s on a regular basis and I can count instances of SD card corruption on one hand. I think it has more to do with poor quality SD cards and power supplies causing write errors over time than any abrupt power offs.

Since the whole GPIO of the Pi is unused in the camera kit, though, it should be straight-forward (ish) to add a shutdown button. If the software is based upon Raspbian- the main OS for the Pi- then there’s a single line you can add to config.txt in order to make it treat a pin as the shutdown button. It’s rather more complicated to physically add that button - requiring some soldering - but we have headers that can be applied with the judicious use of a hammer which can help avoid that.

Microsoft have actually finally started taking steps toward fixing the Notepad line-ending issues that have plagued anyone tweaking UNIX files for years- https://blogs.msdn.microsoft.com/commandline/2018/05/08/extended-eol-in-notepad/


#13

I had a similar experience: got photos initially then the red light refused to come to life; after re-booting the green light now doesn’t illuminate. Power source is OK when plugged into my phone. Using a separate power source doesn’t make any difference. Not sure what to do next…


#14

What power sources have you tried?

I may have to eat my words from above and suggest this is a classic case of SD-card corruption, but you should try:

  • Removing and re-inserting the SD card
  • Removing and re-inserting the camera ribbon cable
  • Using a mains-powered microUSB supply

If the above fail, you may need to re-image your SD card by following the instructions here: https://mynaturewatch.net/daylight-camera-instructions

It’s also possible the Pi itself has been damaged- potentially from a short with a metal object.

Edit: I haven’t actually set up one of these cameras myself yet, so I’m speaking from my general experience with the Pi. There may also be more specific debugging information on the mynaturewatch forum: https://mynaturewatch.net/forum?p=%3Fforum%3D675801


#15

In that case I won’t feel quite so guilty the next time I turn my extension cable off while forgetting that pi is still running.

I was thinking about adding a button but I tend to forget about it so the battery has run out by the time I remember to check on it anyway.


#16

I’ve now tried re-imaging the SD card. Initially there was still no sign of life when I connected a mains-powered supply. I tried once more and observed the green led flashing for several minutes but the red led never illuminated and the wi-fi network didn’t appear on my list. I’ve tried again but now no sign of life at all ie the green led doesn’t light up. Should I now be considering sending the hardware back to Pimoroni and asking for replacement parts ?


#17

I’d certainly get in touch with them to see what they say.


#18

Naturewatch camera assembled and started up no problem but froze and lost connection after a couple of minutes. Rebooted with same result. Have tried, different power supply, reloaded software, tablet instead of PC, improved CPU cooler by adding washers as supplementary fins. Same result each time, two minutes of operation.
Any ideas ?


#19

Further to the above. I have also taken out and reinstalled the camera ribbon. THE CPU and heat sink seem to be running very hot. Is this normal ?


#20

I have now tried water cooling the CPU by filling a tumbler with water. Then suspending the board over the tumbler so that the washer extended heat sink just dipped into the water. It ran for an hour before the red light went out.
Do I have a faulty raspberry or camera module ?