New Pi Zero W only working @ 0.70Ghz


#1

Hi,

Just got the new Pi Zero W from you guys today. Great quick delivery.

Loaded it up with latest Pixel software. when i run the following:-
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
I get the following:- 700000
On my old pi zero 1.3 with the same command i get 1000000

If i try and change the config.txt file to arm_freq=1000 when i boot the pi zero w it crashes.

Please help.

Thanks

Murray


#2

Photo of the boot screen.First boot screen.


#3

Second try at booting.


#4

With arm_freq=950 in the config.txt file i get 0.95Ghz.

But anything over and the system crashes. The chip on board doesn’t run at the stated 1GHz.

Faulty?


#5

So with the command like this “#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800” in the config.txt file the chip runs at 700 Mhz. But on the Pi Zero 1.3 with the default config.txt file it is running @ 1Ghz default.


#6

I’ve done my own testing to confirm this problem- it sheds some light about why we were cursing the slowness of the Zero W yesterday while testing various radio/audio distributions.

I have passed a bug report up the chain- right now it seems like a bug and not a deliberate change. I also certainly wouldn’t take it failing to manually overclock to 1Ghz as an indication that it can’t be overclocked to 1Ghz- I’d guess other factors are at play.

I will update this thread with any response I get back.

Edit: Confirmation that someone is looking into it.


#7

For info, I’ve just checked my new Zero W and it’s running at 700MHz compared to my old Zero running at 1GHz.

/edit - For clarification, I’ve not intentionally overclocked my original Zero, that’s 1GHz out of the box. I’ve also just tried running some intensive tasks to get the CPU up to 100% on the new Zero W to see if the speed varies under load but there’s no change.


#8

Update: Confirmation that they can replicate the issue and are looking into a fix.


#9

Thank you for the update.


#10

#11

Updates will be posted here: Pi Zero W: READ THIS FIRST!


#12

This should be sorted now. A sudo apt-get update and sudo apt-get upgrade in the terminal should fix it.