New picade, screen not working


#1

just finished putting my picade together, but i can’t seem to get the screen working. i power everything on, and the screen just flashes on every few seconds. in the top left corner, when it flashes on, it has a blue box that says “hdmi”. nothing anywhere else on the screen in these flashes. i’ve tried unplugging and replugging everything connecting to the screen (and the bits those wires connect to) several times, and nothing’s changing. anyone know what’s going on here, or how to fix it?


#2

silly me. testing it out, i had the machine plugged into my usb hub, didn’t stop to think that maybe it wouldn’t be enough to power the picade. that sorts out the screen flickering, however i’m now stuck at the screen complaining about not receiving a signal. figured maybe the hdmi cable might be defective, so i tried another hdmi. issue prevails. have tried unplugging and replugging everything again, still nothing.


#3

Edit /boot/config.txt on your Pi using nano, or by inserting the SD card into a host computer, and make sure you have the line hdmi_force_hotplug=1


#4

you are an absolute godsend. thank you much, man.


#5

No worries! It’s easily missed but an essential step due to how the screen is powered.


#6

seems i’ve run into another roadblock. trying to run “curl https://get.pimoroni.com/picadehat | bash”, it keeps spitting out “Failed to connect to www.get.pimoroni.com port 443: Connection refused”. i’ve tried on wifi, and ethernet. any ideas?


#7

It shouldn’t have the www in there, not sure where that’s come from. What happens if you run the command without the pipe to bash on the end, so just

curl https://get.pimoroni.com/picadehat

?