On/Off Shim - Bad USB port


#1

Hello, I bought 3 On/Off Shims from you guys back on 5/8/2017 (order PI191653). I just installed the third one yesterday (finally) but this one seems to have a bad USB port. If I have a power cord plugged into it, it won’t work unless I put pressure on the cable in just the right place (like if I push the cord down so the back of it comes up).

My question is: have you guys had reports of this? Maybe a bad batch of these things that can be easily fixed by me somehow? I don’t see anything noticeably different between this one and a working one if I compare them side-by-side.

I’ve included some images, but I don’t see anything obvious. I might just try to pinch the metal housing with pliers and hope that its just not tight enough right now to keep the cable connected where it should be. But do you guys have any suggestions before I do that? Anything that you see in the pictures that might indiciate what the problem is?

Btw the left one in the pic is the bad one (the dusty right one has been working strong in my garage for months).

PS, ugh, new users can only put one pic per post…


#2

Another image.


#3

Update #2, disregard this. It’s not true lol…

Update, I’m thinking it’s not the USB plug, and instead either a solder joint of mine (likely) or another internal component. Once it’s on, moving the USB around a whole lot doesn’t do cause it to lose power. What it must be is something related to the button perhaps that isn’t working until I wiggle the board (or the USB cable plugged into the board) around enough


#4

Try redoing the solder joints and if that fails it might be best to email support@pimoroni.com for a replacement.


#5

Ditto to redoing the solder joints. You don’t need that much solder on each joint. The blobs on the ends of the pins won’t help either. You want it concentrated down where the pad on the circuit board meets the pin.
https://learn.pimoroni.com/tutorial/sandyj/the-ultimate-guide-to-soldering


#6

Yep. First debugging step is to reflow those solder joints, without adding any fresh solder, just re-melt them for a couple seconds. If that doesn’t work, you could try running your soldering iron across the set of very small pins at the back of the micro-USB connector, in case one of them isn’t quite soldered correctly. Failing that, email support@pimoroni.com and we can get a replacement sent out.

P.S. I’ve upgraded you to a basic member so that you can post as many images as you like (within reason!)


#7

Thank you everyone. Please disregard my last “Update” (the one where I incorrectly concluded that moving the wire once it’s booted doesn’t cause the power to get lost). My description from my first post is the most valid one.

I double checked my solder points and they seem solid. I cleaned it real good with some 99+% alcohol, dabbed it with flux and even added a little solder (so it’s a little blobby, but no connections touching, and it looks pretty solid).

I hit the 5 points on the usb power, and even the housing mount points (or whatever they’re called) on the board.

Unfortunately, the same problem exists stlll. I created a video if that’s helpful at all (about halfway into the video I zoom out and its more apparent what the problem is, I think):

I will email support and see if they have any recommendations. A replacement would work, but if there’s anything I can do to save the hassle of shipping a single on/off shim across the world I would be happy to try it :).

Last thing worth mentioning: it appears both the good working shim and the one with this problem have about equal “wiggle room” for the USB port. So the bad one isn’t extra loose or anything.

Thanks again!


#8

Have you tried a different power supply, to rule out the possibility that it’s the connector on the supply? Also, it looks like the power cable might not be pushed all the way in?


#9

Ugh ok I feel like an idiot. I wanted desperately to reply and say “yes I tried that, DUH!”… but no I didn’t. I’m using my Samsung S6/S7 plug now and I cannot make it fail… I’m shaking it by the power adapter, pushing it around to each side, and it’s staying on.

In case you’re curious, the other plug is a Vileros 2 amp power cable I got with some Vileros Pi Kit a couple years ago. I’ve used this plug probably more than any others across at least a dozen different USB plugs (between various Pis, phones, and even these On/Off Shims) and this is the first one it’s been a problem with (in fact, the onboard pi-zero USB power plug works fine with it). I think maybe the plug is a little smaller perhaps on the power adapter, and this particular shim is a little more finicky than the other two I have.

Btw, in the video it looks like it’s not plugged in all the way, but for whatever reason, this USB adapter is a bit longer than the average one and it was indeed plugged in all the way.

I’m going to chalk this up as 70% me being a dummy and share the remaining 30% between the shim and the power adapter and consider this a non-issue, lol =).

Thank you guys!


#10

Haha. Not a problem. Really glad you got it resolved! There definitely is some variation in those male micro USB connectors. I’ve come across similar issues in the past.