One line bash script error


#1

I get the following error when I use the bash one liner script for setup for scrollphat

Updating apt indexes...
..................W: Failed to fetch http://dl.bintray.com/pipplware/dists/jessie/main/binary/./Packages       403  Forbidden

W: Failed to fetch http://dl.bintray.com/pipplware/dists/jessie/armv7/binary/./Packages  403      Forbidden

E: Some index files failed to download. They have been ignored, or old ones used instead.
Apt failed to update indexes!

#2

These aren’t normal Raspbian apt sources, what OS are you running? Or have you manually added these “pipplware” sources?


#3

i am on retropie 4.2. I have not added pipplware sources. where do i find these?


#4

Honestly, it’s only via the good graces of Google that I’ve any idea what pipplware is. It looks like RetroPie supply a Kodi installer that relies upon their sources. It could be either their sources, or your internet connection, that are at fault. Have you tried running the installer again since?


#5

I have tried running the installer serveral times. Unfortunately I get the same error. I understand retropie is an experimental OS for scrollphat


#6

Well in this case, the OS’s package management is fundamentally broken by a bad package source. There’s not much we can really do about that automagically.

You may have to dig around in /etc/apt/sources.list or /etc/apt/sources.list.d to find and disable this source.