PantiltHat Electric Test

I try to use the PantiltHat with a FT232H device on a Ubuntu system. But until now I could not get the Pantilthat responding. I am trying to check at least the correct connection
I measure only 1V between the 5V pin and the ground, so I suspect either a damage on the board, or a power supply NOK.
Did someone use the Pantilthat with the FT232H (or other non Raspberry system)?
Is there a method to test the correct power supply?
What is the current consumption (with and without servo movements)?

The Pan Tilt Hat pinout is here,
Pan Tilt HAT at Raspberry Pi GPIO Pinout
You need to have all the ground pins marked with the black horseshoe shaped blobs connected up to ground.

Thank you “Alphanumeric”.
Some news: there was obviously a mistake in my wiring, I did 2 things

  • Used a separate 5V power supply (not using the 5V of my FD232H board), as I have seen that the current available by FD232H was not enough.
  • Connected all the “Ground” as alphanumeric said. Grounded also the FD232H board with all the grounds from Pantilt board. (Note; I did not connect the 5V of the FD232H to the 5V of the Pantilt, each one has its own power supply, the pantilt power comes from a 220V-5V all-purpose power supply, the FT232H is taking his power from the USB line
    Unfortunately, no change in the behaviour.
    I have one doubt: in the pintout page proposed by alphanumeric, there is a the pin GPIO16 (pin 36), I do not know where to connect it. Any clue?
    I checked on the test points, now I have correct tension (5V), what else can I check to understand what is wrong?

I don’t think you need to worry about the eeprom pin. How are you trying to control it?

Thanks a lot for your efforts to help me.
I try to access through the pyftdi routines. For example, I tried to detect which address is responding with the following python program and all answer “NACK”
from pyftdi.ftdi import Ftdi
from pyftdi import i2c

ctrl = i2c.I2cController()
ctrl.configure(‘ftdi://ftdi:232h/1’,frequency=200) # it tried also 1000, 9600… no difference

for add in range(1,127):
port = ctrl.get_port(add)
print(“Test address”,add)
lu =
print(“Read: [”,lu,"]")
except i2c.I2cNackError:
print(“Nack error”)

print(“fin de l’essai”)

I have never used pyftdi. I don’t think I can be of much help there. I don’t have anything handy to run it on.
For what its worth I have two Pan Tilt hats mounted to Pi 3A+'s. Both are running Motion Eye OS. Motion Eye OS now has support for the Pan Tilt Hat included, but it was still a fair bit of work to get mine working. It’s based on BuildRoot and is really locked down.

Just curious as to what Camera your using and are you running Ubuntu on a PI?

Hi, indeed I do not use a Raspberry, but directly a laptop with Linux Ubuntu 20. That is why I need to use the FD232H board to go from USB to I2C. I have fixed a standard Webcam on the Pantilt. My application is intended to make movie of people playing tennis.
Thanks for your help anyway.

Ok, I think you have your work cut out for you.

ctrl.configure(‘ftdi://ftdi:232h/1’,frequency=200) # it tried also 1000, 9600… no difference

I2C more commonly has speeds of 100000 or 400000 Hz, so those may have been low. Try 100K or 400K.

EDIT: Also, using I2C with this board seems quite complex, so using Adafruit’s Blinka method may be easier.

Thank you Shoe, I’ll try it as you said, let me a few days (I have also a “normal work”) :-)