Patriot 256 SSB - Cant see drive on PI 5 or Mac

I have bought the NVMe base and the 256 SSB card, easy installation and ran PI Imager on the PI 5, I could see the drive and I started loading the Ubuntu operating system from an image I had loaded on a USB stick also attached to the Pi 5, all was going well until 96% and it hung. On reboot I could not see the drive come up on PI Imager, I have since bought an external USB NVMe but still cannot see the drive on the Mac so I am wondering what else I can do, is the SSD faulty or did the 96% write then hanging somehow destroy the drive?

Thanks for any suggestions

With the SSD in the USB adapter can the Mac’s Disk Utility not even see the Patriot drive so you can use First Aid or Erase options on it?

I used the same technique as you to put RaspiOS on my 512GB Patriot and it worked perfectly allowing me to plug the USB combo into my Pi5 and boot off it before I fitted Pimoroni’s NVME Base.
Not tried Ubuntu though

I bought the external USB reader so I could test it on the Mac but no I cannot see it in the disc utility, so I cannot run any first aid or format it ,
Thanks for your replay,

Might be a faulty SSD, I have the exact same setup and it works perfectly

Thanks for your message, I have another SSD and its worked straight away, I will contact Pimoroni as I believe you are correct and its faulty, Steve