pHAT DAC ALSA error


#1

Hi folks,

I just received my Raspi Zero W and the pHAT DAC, installed Raspbian Stretch Lite, changed the sudo user to a different name than pi and followed the tutorial to install the dac libraries (https://learn.pimoroni.com/tutorial/phat/raspberry-pi-phat-dac-install)

However, when I run
curl https://get.pimoroni.com/phatdac | bash
for a second time, I’m getting the following error when testing the speaker:

speaker-test 1.1.3

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib confmisc.c:767:(parse_card) cannot find card ‘0’
ALSA lib conf.c:4528:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4528:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1246:(snd_func_refer) error evaluating name
ALSA lib conf.c:4528:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:5007:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM default
Playback open error: -2,No such file or directory

boot/config.txt looks good to me. Does anyone have an idea what could have went wrong?

Many thanks in advance for your support :-)


#2

What do you see when you run:

aplay -L

and

aplay -l


#3

aplay -L
gives
null
Discard all samples (playback) or generate zero samples (capture)

and
aplay -l
gives
aplay: device_list:270: no soundcards found...

soldering is fine and the board is connected the right way. maybe it’s broken?

or is this an issue with debian 9 (stretch)?


#4

Sorry for the late reply- did you have any luck?

Audio-out should work even if the board isn’t connected at all, since it just wiggles some pins in the right way and has no idea a DAC is connected, so this must be a software issue.

Seems audio isn’t enabled at all in your case- what was in /boot/config.txt?


#5

I’ve switched back to debian 8 (jessie), did the same installation again and it works perfectly.