Phat touch - Button B less responsibe


#1

I tried my new phat touch for the first time. I ran the buttons.py to check the functions. All LEDs an buttons work, but button B is less responsive, compared to the other buttons.

While other buttons have to be touched, to be active, button B has to be pressed hard, otherwise it doens’t notice the press.

I’m using a pi zero w with RASPBIAN STRETCH LITE and pi hole installed and running, as the only application. The soldering looks fine. I want to use the phat touch for control pi hole.

Any suggestions?


#2

hello,I’m no pro ,so what i do with issues like this use another SD card and use a full install of raspbian and try running it there


#3

Try cleaning the surface (with the power off). Alcohol if you have some. Glass cleaner is probably OK to use too, just don’t put a lot on it. Spray a paper towel and wipe the buttons with it. Let it dry then boot it up and give it another test.


#4

Thanks for reply. I disconnected the phat (after shutdown) and reconnected it again. I didn’t do anything else. Now the button works fine.

I still don’t know the reason, but the problem is gone.


#5

Weird, but at least it worked. Hopefully it keeps working OK now.


#6

i have had similar issues with my drum hat,sometimes when i start it up not all sensors work when touched , and i have to restart it to get them all working