Pi5 Breakout Garden Sorry, I couldn't find any breakouts!

Hi All,

New here. I just put together a Pi 5 with the latest Raspberry Pi OS (64bit) released: 2024-03-15 and ran updates.

Then mounted the Breakout Garden for Raspberry Pi (I2C + SPI) PIM445. I also enabled I2C in raspi-config.

Plugged in three breakout garden modules:

  1. 3DOF Motion Sensor MSA301
  2. 9DOF Motio Sensor ICM20948
  3. 8x8 TOF Array Sensor VL53L5CX

I went to the git repo by clicking the link under the SOFTWARE heading on the Pimoroni Breakout Garden web page and looked for something called, “automagic installer,” but couldn’t find that. So, I followed the readme.md installation instructions steps 1 through 5, but got stuck there. After running the sudo ./install.sh command, I got the message, “Sorry, I couldn’t find any breakouts!”

This is my first time with a Pi 5, the latest OS, and anything Pimoroni. I’m sure I’ve done something wrong. (The breakouts are not in backwards, as I saw in another post.)

Does anyone see where I got off track?

I feel like I should load libraries for the individual modules, but am unsure how to proceed. Are there any other dependencies I should be aware of?

Any help is greatly appreciated.


Make sure i2c is enabled in Raspberry Pi Configuration. Might also want to enable SPI while your there.

Hi Alphanumeric,

Thanks for the reply.

On my first running of the script, I had not enabled I2C in raspi-config, but it was smart enough to notice that and enable it on its own. I still got the couldn’t find breakouts message. After reading some online posts, I enabled it manually, and still got the same message, even after rebooting.

What do you see if you run sudo i2cdetect -y 1 from a terminal window.

There are individual installers for each breakout by the way.
GitHub - pimoroni/msa301-python: Python library for the MSA301 3-axis accelerometer

GitHub - pimoroni/vl53l5cx-python: CTypes Python bindings for the VL53L5CX

GitHub - pimoroni/icm20948-python: Python library for the Pimoroni ICM20948 breakout

It doesn’t detect any of the three modules plugged into the Breakout Garden.

I’ve tried installing all three of the packages from the links you provided, but get the same error with each:
error: externally-mamaged-environment

Here’s what I used (for example):
python 3 -m pip install icm20948

I tried:
sudo apt install python3-icm20948
and got:
E: Unable to locate package python3-icm20948

The above error message has to deal with the new Virtual Environment.
Virtual Environments, Libgpiod, gpiodevice and the current mess I’m making of our Python libraries - Support - Pimoroni Buccaneers

If i2c isn’t detecting anything there is a connection issue. Do you have the hat firmly attached to the GPIO header, and the right way around?

Hi Alpha,

Yes, Garden is installed correctly and pressed all the way down.

I removed it and installed on a Pi 4, ran through the same installs as I did on the Pi 5, and now the address shows up in an i2cdetect.

Something else weird about the Pi 5 is that it believes my power supply is insufficient. It’s a 10A supply and I’ve set the output everywhere between 5.0 and 5.5V, ans I still get the same supply message. Related? I didn’t think so, but…?


My guess about the Pi 5 i2c issue is its related to it having the RP1 chip. It’s what interfaces with the GPIO header.

As far as the Pi 5 power supply issue. That’s likely because it can’t negotiate the 5V 5A connection with the connected USB C power supply. When that happens it limits the max current available to the USB ports. There is a config.txt edit to override it.