Breakout Garden can't find any breakouts

Hi, just purchased a Breakout Garden and a couple of breakouts to have a play with.

I have hooked up the Breakout garden, and put the IOExpander Breakout in (also tried with the Potentiometer Breakout, same result). Using i2cdetect I can see that the breakout is hooked up because I have entries in there which are only populated when the breakout is connected (0e for the Potentiometer for example).

However, when I run it says no Breakouts found. (I am running it with sudo, obviously). this is using the latest master from GitHub.

Any ideas what obvious step I’ve missed?

Thanks in advance for the help


I don’t bother with that utility. Just personal choice, I like to install each breakout manually one by one. Both of those breakouts use the same library, which might have something to do with the utility not working correctly and or making you install manually.
pimoroni/ioe-python: Python library for the Nuvoton MS51 Pimoroni IO Expander Breakout (

1 Like

That’s great, thanks, I’ll give that a try!