Picade 10 (3b+version) recognize my stick and button as keyboard (not gpio controller)

Hi~ I’ve been using this picade 10 for several months without any problem.

But, suddenly it occurs.

This is what I did with several images.

  1. Make image and put SD card into my picade 10.
  2. Boot with usb keyboard.
  3. Connect wifi win Setup Menu.
  4. F4
  5. curl https://get.pimoroni.com/picadehat | bash
  6. shutdown -r now
  7. Configure Input -> Click my buttons -> It shows ‘keyboard’ (not Gpio Controller~ )

It recognizes my stick and button as keyboard, so when I connect the real keyboard, My stick and botton doesn’t work.

I tried tried tried with several images, but all failed.

In several months ago, there was no problem.

Any changes in picadeHat download after new PicadeHat X (for raspberry pi 4) release?

plz, help~ thanks.

Hi,

The X HAT software sets it up to emulate a keyboard, so in Emulation Station when you press an arcade button at the start of the wizard it correctly shows ‘keyboard’. When you connect a real keyboard, the arcade buttons and joystick should continue to work as a ‘keyboard’ at the same time. You can test this by hitting F4 to go to the terminal, then press the arcade buttons or move the joystick. The joystick should move the cursor, and some of the buttons will produce letters in the terminal (some of the buttons emulate non-printing characters so you won’t see anything on screen for them).

As far as I can tell, there haven’t been any changes in the picade software for the new X HAT.

You’re not the only person to struggle with this type of issue. I think the build instructions that Pimoroni provide are inadequate when it comes to installing the X HAT software and configuring Emulation Station, especially when this stage goes wrong.