Picade 10" screen - powers off 10 sec during boot, RaspPi 4, Retropie (Buster)

Hey folks! This is a weird, weird one. Can confirm the system is trying to boot and power gets to the driver board (LED comes on), but then it flips off after about 10 sec into init. syslog shows the EDID is invalid and totally zeroed out. hdmi_safe, force_hotplug etc. don’t work. Is there some magic config line I should use to try & get it booting? (I’ve got another SD card on the way to rule that out.)

As a followup: removed the Pi from the equation and plugged a direct USB power source in. Board lights up, but display is still blank. Not sure if this is expected, or if I should at least get something to confirm the display is good.

Leave the Picade hat off. Plug the monitor into the Pi and power it up before booting the Pi up. If you have a spare Pi power supply I would use that for the monitors power, just for testing. And if its not to much of a pain I’d use just PiOS for this test. You just want to make sure the monitor works with a stock install, it should work like any other monitor.
If you get that far then you know the Pi is fine and the monitor is fine.
Then add the Picade hat to the mix and go from there.

Tried it with a stock PiOS install, a new HDMI cable, separate power to the display and Pi and with the HAT removed:

[    12.051] (II) modeset(0): Output HDMI-1 has no monitor section
[    12.053] (II) modeset(0): EDID for output HDMI-1
[    12.053] (II) modeset(0): Printing probed modes for output HDMI-1
[    12.053] (II) modeset(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[    12.053] (II) modeset(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[    12.053] (II) modeset(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz e)
[    12.053] (II) modeset(0): Modeline "848x480"x60.0   33.75  848 864 976 1088  480 486 494 517 +hsync +vsync (31.0 kHz e)
[    12.053] (II) modeset(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[    12.053] (II) modeset(0): Output HDMI-1 connected
[    12.053] (II) modeset(0): Using exact sizes for initial modes
[    12.053] (II) modeset(0): Output HDMI-1 using initial mode 1024x768 +0+0
[    12.053] (==) modeset(0): Using gamma correction (1.0, 1.0, 1.0)

So it looks like Xorg is correctly talking to the driver board at least, but the monitor still displays no output. Guess I’ve got a duff screen?

If it’s a PI4B which HDMI jack are you using? You need to use HDMI 0 which is the one closest to the USB C power jack.

That’s the one I’m using.

Ok, what you posted above is referencing HDMI 1, which is why I asked.
I’m as confused as you are? I don’t own a Picade, just so you know.
One thing I do know is, if my monitor isn’t plugged into the Pi and turned on when I boot up my 4B, I get no signal on the monitor. And I have to reboot the Pi to get a signal.

Ah, good catch - must’ve missed that when I caught the output. Tried again confirming it’s in HDMI-0, and still nothing, even with the display powered before turning on the Pi. Very odd.

So. Guess who somehow managed to plug the cable in backwards, then broke the connector off when trying to fix it? Time to pay the stupidity tax.

Don’t drink and DIY, kids.

You know, with those Micro HDMI and Micro USP, it’s not all that hard to mess one up.
You could still us that Pi headless. You may have to do the setup on another Pi, but it’s still usable for certain things. And there is probably a config.txt edit to force the output to HDMI 2. DSI likely still works OK too.