Picade Plasma buttons - change boot color?

Im pretty new to the raspberry pi scene, i have no experience with working with scripts and commands from before (MacOS plug&play guy :P)

I have a question about the plasma buttons on the picade.
I’ve installed them and everything seems to work, it boots and i can test out new colors in terminal and so on.
But… how do i change the default colors so that it’s not “rainbow” when booting anymore?

I’ve made my own png and installed it, even tried to replace my png with the default one in /etc folder (by namning mine default).
but that did not work.
I used the file manager inside retropie to do this btw.

Any ideas?
if there is a script that i can run or similar, please write it in full here so i can copy/pase it, like i said, im new to this.

I believe its as follows.
Install a new pattern, where is the filename of a 24bit PNG image file
sudo plasmactl --install <pattern>


yeah i’ve done that and it works fine to install my new pattern, looks great when i test it out.
But how do i set it as default?

When i boot up my picade it goes back to the rainbow pattern again.

I had a look at the notes I made when I ran Plasma on my blinkt
Try this
sudo nano /usr/bin/plasma
look for a line with load_pattern(“default”) at the end
I changed it to load_pattern(“trippy”) and it switched.

well, i feel a bit stupid.
i managed to break something, now, the plasma wont even start anymore.

i found the file:

def load_pattern(pattern_name):
pattern_file = os.path.join(PATTERNS, “{}.png”.format(pattern_name))
if os.path.isfile(pattern_file):
r = png.Reader(file=open(pattern_file, ‘rb’))
pattern_w, pattern_h, pattern, pattern_meta = r.read()
pattern = list(pattern)
log(“Loaded pattern file: {}”.format(pattern_file))
return pattern, pattern_w, pattern_h, pattern_meta
log(“Invalid pattern file: {}”.format(pattern_file))
return None, 0, 0, None

Wrote the namne of my png and saved.
After that the plasma wont work at all.

When i try it in terminal it just says:
/tmp/plasma not found.
Plasma daemon not running?

Best guess is you made a typo?
I would delete the plasma directory, and then see if you can reinstall it all over again.

git clone https://github.com/pimoroni/plasma
cd plasma
sudo ./install.sh

cd daemon
sudo ./install.sh

Alternatively, you could try editing the file again.
The following may come in handy.

sudo systemctl stop plasma
sudo systemctl disable plasma

sudo systemctl enable plasma
sudo systemctl start plasma

thanks! you were right!
I’ve must have made a typo or something, after playing around a bit more it worked!
My own png is now the default boot for the plasma.

Thank you so much for all the help! :D

Thats great to hear. Been there done that (typo). ;)
I don’t own a Picade, but did play around with Plasma on my Blinkt.
It even works with the “1” Led on the fan shim, lol. I found that out by accident.
It actually looks pretty cool on the Blinkt with the default color changing pattern.