Picade + RPi4 = WiFi not working :(

So I started a thread on the RetroPie forum but after yet more investigation is seems to be something physical - but I can’t see what :S

In summary…

RPi3 + Picade HAT + Picade 8" = WORKING
RPi4 + Picade HAT = WORKING
RPi4 + Picade HAT + Picade 8" = WiFi won’t obtain IP address, but scan and signal strength return OK

Now, I’ve also tried lots of different configurations. I have 3 images I’ve used - Vanilla Buster Lite, PxlTbl (a working image from a very similar project I have, laser-cut case, 7" screen, pimoroni audio hat). I have an RPi3 and 2 RPi4s.

All the Pis work with all the other images and I’ve not got/had any issues with WiFi. I’ve rebooted all my network equipment, it’s quite a complicated setup but it’s all DrayTek business class stuff (I’m a DrayTek authorised reseller).

If I put the Picade hat on the RPi4 and leave on my desk - it works. If I assemble everything, just can’t get WiFi to work well enough to obtain an IP via DHCP. Assigning a fixed IP doesn’t solve the problem, I still can’t ping or send traffic. If I rebuild it with a RasPi3 - everything works just fine.

Any ideas?

So I’ve now got to the point where I can create the issue and resolve it…

All I have to do is take the RPi4 out of the Picade but leave it all connected up and it works fine dangling out of the back.

If I mount it in the proper place I get packet loss and pings of a few 1000 ms. This only happens with a Pi4, the Pi3 works fine. Iv’e not tried a USB WiFi dongle yet.

Today, after weeks of working from home, I seem to be havving massive WiFi issues with my laptop. It’s been perfect literally up until this morning.

So I ran a WiFi scanning app and it turns out one o fthe neighbours has cloned our WiFi. So my laptop was connecting to the dodgy WiFi instead. Now this isn’t the exact same issue, but it all seems connected. I’ll investigate further. Maybe the RasPi 3 somehow has a preference for my WiFi and the Pi4 for thiers? both are jsut configured using SSIDs so it’s not like I’m entering the details any differntly.

IMO the problem you’re facing must be a universal one facing all pi4 Picade users. I was going crazy tying to figure it out myself. Like you, sometimes I would think that I solved the issue, but then mysteriously the problem returned. This only affects 2.4Ghz WiFi, and the reason is interference. The pi4 is sensitive the hdmi interference, as you may have read at some time during your time googling for a solution. This isn’t a problem with 1440p resolution only however, but affects all resolutions. Here is the best thread that confirms the issue, and brought some sanity back to me:


I actually have the Wi-Fi working 100% now (crossing fingers) by replacing the micro usb to hdmi cable included with the Picade with the official 3 meter raspberry pi cable, and moving all usb devices over to the usb 2.0 ports (my external hd and keyboard). Apparently usb 3.0 ports also cause some interference as well.

I hope this helps you, but YMMV.