Picade USB-C with Pi 4 no ALSA audio device detected

Hello,

I build a Picade 8" with a Pi 4 inside. Everything went quite smoothly but after installing a raspbian with NOOBs and the picadehat install script, it still doesn’t detect any audio device.

I did install a raspbian since I don’t know if retropi works correctly on Pi4, the download section seems to have only 1 and 2/3 versions…

There is a small red x on the volume control, and when opening sound parameters, I get the following error message:
no ALSA audio device detected

Any idea how to make it work ?

Thx

I don’t know for sure if its an issue, but me personally, I wouldn’t use NOOBS to install Raspbian.
I would get Raspbian from here


And use Etcher to flash the image to my Micro SD card.

NOOBS can put a wrinkle into things with the extra partitions etc it creates.

I see, so it could cause problems with drivers installation for instance ?

Yes possibly. It would depend if the installer knows what to do if it sees a NOOBS installed OS. I’ve seen a few posts where somebody has gone to edit file only to discover its not where the tutorial says it should be. The tutorial assumes your running a standard Raspbian install.
I only ever run Raspbian or Motion Eye OS. And both can be imaged just fine with Etcher.

I’ll try this. Thank you very much

Does RetroPi run on top of Raspbian?

I didn’t try yet, but from what I read, it should. The thing I don’t know is if it can run on a Pi4…

I think its more of a “will it run in Buster” deal? Gaming is one thing I haven’t done on my Raspberry Pi. Not yet anyway.

Hi, I am having the exact same issue as the OP.
Rasbian was installed fresh to an SD card via Etcher.
The version is Buster from 2019-09-26 with Kernel version: 4.19
the following was added to the /boot/config.txt
hdmi_force_hotplug=1
Right after raspbian was installed I ran the following:
sudo apt update
sudo apt upgrade
reboot
#wait a bit
sudo rpi-update
#wait a bit
curl https://get.pimoroni.com/picadehat | bash
reboot
#wait a bit

Everything else on the Picade X HAT works except for the sound.