Pichat Zippy Joystick issue in Mame - 90 degrees out of sync


#1

Hi,

I’m having an odd problem with the zippy joystick in mame and would appreciate any help or suggestions.

I’ve bought and assembled the pimoroni pihat and joystick/speaker/button combo kit into a custom cabinet with a waveshare ui and a pi 3b.

I’ve followed the pimoroni picture based tutorial/examples to ensure the wiring is correct and all has fired up fine with a fresh distribution of Retropi.

Originally this bought up the lightning symbol showing I didn’t have enough power so I’ve replaced this with the pimoroni 2.5a power supply and all is working fine and the lightning signal has gone.

I’ve then configured the joystick and buttons in retro pi and can use the joystick to navigate the emulator station menu and all actions and buttons appear to work fine.

However, when I fire up a game in mame, the joystick actions appear to be 90 degrees clockwise out of sync in all games, so I move the joystick up and it registers as left, move the joystick down it registers as right in the game.

I’ve checked the pin connectors and all seem fine on the zippy and the cable is nicely secured into the hat.

If I try mapping the controls in game in mame (tab menu) then its still doesn’t fix the issue.

I couldn’t find anything by googling, so wondered if anyone has seen this or has any ideas as to why this is happening?

Any suggestions greatfully appreciated :)

Thanks
Darryl


#2

Found out the issue - pin connectors in the zippy were not right :) - configuring for emustation worked, but I’d missed i had registered up as left, which is why it worked on the mame menu, but mame has its own config. Moved the pin contacts around 90 degrees and now works :)