Zippy Joystick Diagonals


#1

Hi, recently built the Picade received for Xmas. Brilliant piece of kit but having issues with the zippy joystick.

Both axes work well enough but having problems with ↖️↙️ . Taking off the control panel again and looking behind the joystick whilst moving it it appears that it is not hitting both switches at the same time.

Moving in the diagonals ↗️↘️ I can hear both microswitches being engaged with two distinct clicks. On the opposite diagonals i can only hear 1.

Any suggestions how this can be fixed? (If at all possible??)

Thanks


#2

I had an issue where one of my wires was tucked up and binding and I had to re-route them… That’s all I got for ya. Good luck.


#3

Thanks, i don’t think that is the issue having looked underneath the joystick and at the wiring but appreciate your reply!


#4

I’m having the same problem from a pre-xmas purchase, same directions as well. Have not worked out a solution so far.


#5

I have the same issue and replaced it with a Sanwa joystick .


#6

Same here. This is the next thing I will do (buy a better stick). I hope Pimoroni assess this.


#7

Hi there,

I had the same problem with down/left and up/left. The Joystick has a restricor plate at the bottom to set it into 2-way, 4-way or 8-way mode. I simply removed this plate and now all eight directions work like a charm. Hope this helps.


Joystick: Diagonal directions not working
#8

Thanks for the tip. I’ll give it a go.


#9

@seeberc haha This worked!

Slightly embarrassing :D

Thanks!!!


#10

No Problem. Just to set this right: my joystick was set to 8-way by this restrictor and should have worked but only removal of the plate did the trick. I think the restrictor is crap, might be useful if you only play Pac Man or Space Invaders …


#11

I’ll probably still get a Sanwa/Siemitsu just because the travel seems a bit longer. Not having much luck getting zangief’s spinning pile driver (requires a quick 360 input).


#12

Spot on for me too! The 8 way setting doesn’t seem to align properly so causes the issue. Strangely enough just removing the top plate didn’t work but I noticed the green plate underneath had a loose screw as well. Tightened that up and it’s perfect


#13

Happy with my Hori Hayabusa upgrade.


#14

Thank god I found this before replacing the joystick… :-) Just removing the green plate resolved it.


#15

Ah, I was having problems executing moves in street fighter. Which part is the restrictor plate? Can someone upload a Photo?


#16

Never mind, I see it is just the green piece of plastic on the bottom. Now that I have removed it, it works flawlessly! Thanks!