Pirate Audio Headphone Amp - No Sound

Hi, I’ve just set up a new Raspberry Pi 4 with the Pirate Audio Headphone Amp.

I’ve disabled the default audio in /boot/config.txt, and can only see one device after aplay -l etc…
I’ve enabled SPI and I2C
Iris launches, I can see the mp3 lists from the local directory, the buttons work, the mini display shows the playing track details (selected from the web interface locally and from my mac), but no sound.

I’ve tried different headphones.

Is there something simple I’ve missed?

I’ve read most / all the related posts although the fixes seemingly have been rolled into the git repository by now.

https://learn.pimoroni.com/tutorial/sandyj/getting-started-with-pirate-audio

[edit] and this: Pirate Audio Headphone Amp Help

Actually I think its

dtparam=audio=off

and

dtoverlay=hifiberry-dac
gpio=25=op,dh

In config.txt

Thanks, alphanumeric: here’s what I’ve got:

# Enable audio (loads snd_bcm2835)
dtparam=audio=off
 
[all]
#dtoverlay=vc4-fkms-v3d
dtoverlay=hifiberry-dac
gpio=25=op,dh

Everything else seems to be working fine (thumbnails, gui, comms from the buttons to the web app and vica version… all except sound.

Ok, I only have the older pHat Beat based Pirate Radio that drives speakers.
I’ve only ever used VLC Radio to stream from the Internet.
Do you get any sound at all? Have you tried switching the switch on the back to High gain?
I’m thinking its likely a software issue, some config file that needs an edit or some setting that needs to be changed.