No sound from Pirate Audio Smol Speaker


I’ve followed all the instructions for the automatic setup, it is connected to Spotify and I’ve tried playing audio through Iris, but there are no audio outputs listed and nothing is coming out of the speaker.

As far as I can see everything is plugged in fine.

Any ideas?

Running on an RPI3 on Raspbian Buster.

Make sure onboard audio is disabled in /boot/config.txt


Worked perfectly, thank you!

(Probably needs to go in the instructions though)

For thorough instructions and solid code, buy Adafruit

Have had a few experiences I regret with product like Hyperpixel 4.0 and now this PirateAudio due to Mopidy being janky as hell when you throw a large database at it.

Frankly pointing you in the direction of an installer from cloning a repository ain’t much good for say 9 out of 10 customers and will limit your market. Better effort on code and guides would be welcome for most I’m sure.

1 Like

Yes. Hopefully the Pirates are listening.
I did 3 Raspbian re-installs plus endless fiddling and would have carry on without your help, so thanks again.

Yes, Adafruit documentation is beautifully done, I like their Thingiverse models/videos as well.

(Probably needs to go in the instructions though)

Since it’s all on GitHub, you could raise an issue on there. Or even submit a pull request with the improvement.

Since working sound is essential to this phat, I’d expect it to be there already and tested for!
Raising an issue is a good idea. Update: Done.

I did look at buying the Hyperpixel 4.0, but after wildestpixel’s comments, I’m going wait until customer beta testing is over.