Pirate Audio: 3W Stereo Amp for Raspberry Pi

Trying out my new unit. Plugged into zero w and all s/w loaded fine.
symptoms:
Display blank. Lights up but nothing on it.

Iris is installed and working, can connect to web server but nothing is displayed or played on the unit.

Have you tried this https://forums.pimoroni.com/t/no-sound-from-pirate-audio-smol-speaker/12223/2?u=inky_72 and/or this https://github.com/pimoroni/pirate-audio/issues/9#issuecomment-569747828 ?

Yes
I have checked all that, not my first rodeo
The media I am playing is local based so no timeouts. It was playing fine to a bt speaker before I added the hat. I removed the bt link when I installed it.

I will reflash the sdcard. but I don’t see why the display isn’t working either

OK reflashed an now have sound but still no screen display.
Fresh install of Buster lite (2019-09-26). Fully updated
Clean install from git repo.

Nothing else installed just what the repo installed.

I reflashed another card to check on my zero w (have it working on my 2 b), I used 2019-09-26-raspbian-buster (lite didn’t work for me the first time). It took a couple of times to get it to work on my first pi, the dac worked, but the screen didn’t. I followed the steps in the second link that I posted in my original reply & the screen burst into life (it showed the link to the iris server). It also took a few attempts to get the screen to show what song was playing from my local files, I had to scan my library from the iris webpage a few times.

I don’t use spotify so ignored those instructions.
for lite you need to add a “sudo apt install git” or it will not download the repo.
As I said iris is working as I can connect to the web page.

Hi Guys,

the pirate audio came to me as a gift this christmas and yesterday i had finally some time to see the thing in action… i used the install script and the raspberry zero booted, the lcd screen turned on and i connected to iris website from my computer. so far so good.

i put some mp3 on my music folder in the homedirectory off the Pi and did a scan… nothing turned up…

question 1: where can i put my music files?

second problem was mopidy-spotify, i followed the instructions and filled in the info about my account and all the special client id and secret. after that i saw some spotify playlist but i get the error (which i didn’t write down (and i’m at work now)) that the song can’t be played.

In the setting menu was a notice that mopidy-spottify wasn’t running.

question 2: what steps do i have to make to get this working…

thanks in advance

ps if this isn’t the right path to ask this please give me directions how to do this problaly

bytheway i’m not a native speaker :-)