Pirate Radio no wifi


#1

Hello all. Absolute beginner here, some knowledge of DOS CPM and BASIC from the stone ages and I’m able to use Scratch with the help of an 8 year old. So to the problem, bought the Pirate radio kit with the idea of making it with my own 8 year old, the build went well and no problems following that. Linked the assembled unit to the monitor and used the built in editor to rewrite the supplicant file, no problems. However there is no recognition of wifi or internet. Tried several internet suggestions but as I say I am a complete novice when it comes to the Pi. I bought the NOOBS 16G card from Pimoroni to avoid programming problems. BTW the wifi icon on the desktop says no wifi device associated. Is the wifi chip dead? Is it a faulty unit? Any help appreciated.


#2

The WiFi SSID and password are case-sensitive, that’s a common gotcha with this setup.

What do you see if you run: ifconfig in the terminal?

And does dmesg show any errors that might be relating to the wireless hardware.

Also, power can sometimes be an issue- what power supply are you using?


#3

Thanks for the reply. I got the wifi working by downloading NOOBS and installing the online version. Hooray! However on setting up the phat beat all seemed to be going well until reboot and nothing, the vu meters are lighting up, and it appears that I can change channels but no sound at all. Little bugged that the NOOBS card from Pomoroni didn’t have the necessary software on it for it to work with the Pi. Power is from a stand alone raspberry Pi power adaptor.


#4

If you’re keen just for your Pirate Radio to work with no fuss, I’d suggest trying out Pirate Python Radio. We’re working on making an SD card release, or downloadable image, that involves no hassle/setup, but that’s still a work in progress (my fault! I’m the one-and-only-software-guy).

We’ve got quite a lot of our libraries into NOOBS/Raspbian, but unfortunately Pirate Radio is a bit unique in its setup to be included.

You can find the pHAT BEAT/Pirate Radio software: http://get.pimoroni.com/pirateradio-v20171113.zip

This you should be able to extract this to a fat32 microSD card, configure your wifi by editing wifi_supplicant.conf and just plug it in a Pi to have it fire up and start playing.


#5

Thanks. I’ll certainly give it a go. Must admit I thought it would work out of the box and not need any tweaking.


#6

Tried the pirate pyton radio thingy but no luck with it. Didn’t find the help file overly useful and was unable to use my keyboard with it. I’m surmising that i could edit the necessary files on my pc before putting the sd card into the raspberry.


#7

Yep, that’s the intention. And once edited, PiratePython is designed to run headless like an appliance.


#8

Changed the config.txt added dtparam=audio=on and now I get really crappy sound through the monitor, still nothing from the radio. Getting boring!


#10

dtparam=audio=on just enables internal audio, which wont help here.

Could be a signal issue between Pi and pHAT BEAT. How are the Pi Zero W and pHAT BEAT headers attached? Hammer, or solder?


#11

It’s the hammer fit, I have soldered but nothing like this. If i were to pop a little solder in the pin holes would the connection be more guaranteed?


#12

The hammer-headers are usually pretty reliable, so I’d be more inclined to suspect soldering than hammer headers.

Could you run:

aplay -L
aplay -l

and post the results- that’s an uppercase and lowercase L.


#13

I’ve run this now as suggested, and per readme file. Nothing through the speakers, VU meters is lighting up as if audio is playing.


#14

Could you post the results of running those commands? So I can see if everything’s set up as expected.


#15

Apologies for the delay in replying but I had to reformat a card and re load the os. Surprise surprise the thing sprang to life! It not for long but there was sound. It appears that the hammer headers are the problem and theat the connection is not as it should be. A little waggling gave sound for a while, but when I felt that the connection was positive the sound vanished. I’ll try looking at the header again and see if that makes a difference. I did put in the aplay -L/l commands but I’ve no way of transferring so much information to my pc.


#16

Yeah! Pirate Radio up and running! The hammer header contacts were not good and further bashing made this good. I’m sure that taking an hammer to microelectronics is not always a good idea, but it’s now up and running. Audio quality is not fantastic, an improvement on laptop speakers, but I don’t think its as good as my tablet. Next step I think is portability, a rechargeable battery possibly. We’ll see. Thanks Phil for your help and suggestions.

Steve


#17

Right it is working and after visiting another post on sound quality I think I have this sussed. However, the vu lights are now all lit up and the only colour is white, any ideas?


#18

Glad you’re otherwise up and running- which guide did you follow? It’s possible your asound.conf might not be set up properly.