Plasma buttons are they garbage? Don’t stay in

I just built a picade 10” and I ordered the $55 plasma kit to go with it and they do not ‘click’ into place and pop up and out constantly.

Made for difficult build for sure but then when assembled they still pop up when using then and I am constantly having to push them back down. Same for the buttons on the side and front. What gives?

howdy, I have never done this myself ,but, in the directions is say this about having your issue ,good luck ,
connect the spade connectors for the button to the spades to hold the PCB in place. If the spade connector isn’t gripping well, then rotate it 180 degrees and it should grip better and if it still isn’t gripping then give the spade connector a gentle squeeze with some pliers before fitting it.

Ahhh yes this is for the PCB that has the LEDs in them. They are fine enough. My issue is the actual buttons themselves. The control plate is too thick for the buttons to ‘snap’ into place.

I’m not dismissing your issue, just a FYI post.
I used the mini arcade buttons with my Pirate Radio. I have them mounted in the top of an old wooden subwoofer box. Quarter inch plywood, they are staying in place, OK.

Do the locking tabs go through the hole?

Yeah but they don’t go in far enough to pop back out so they are just kind of sitting in there lol.

I’ve moved onto other problems that are bigger now. Like as long as the picade hat is installed the pi just keeps rebooting :(

What are you using for a power supply, and is it plugged into the Picade Hat

I am using the official Raspberry pi USB power supply. And it is connected to the hat. If it is connected to the hat that is when it is rebooting. And it does this with just the hat, nothing even plugged into the hat.

If I connect power directly to the Pi it works and doesn’t reboot at all. But I can’t get the front or side buttons to be seen, and there is no audio at all. (Assuming that is because the hat isn’t being powered directly)

Very frustrated at this point as it is a useless brick.

it might be a brick ,my experience long ,but not very technical smart ,so i have been in your shoes many times ,not with this device ,but with many different devices , so you haven’t said a lot about what you tried ,so my suggestion is to start over from scratch , reinstall Raspbian OS to your sdcard do the updates ,install the Picade Board software run this [i know you did this all ready but your starting over]curl | bash , just my opinion ,from my own experience from 6 yrs of trouble shooting a lot of issues with the many different Pimoroni Hats and pHATS i own …good luck

Ugh. I want to use an image I have spent hours and months building and perfecting :( it should
Just work. And I hate that there is no real support
From the company.

yeah ,I guess that was a bit drastic … …but I was just suggestion what I have done myself many time since I got into PI’s , and I would not have don’t anything to the Image you have built up on the SD card your using now ,Enjoy and good luck

Powering through the pi I got most everything working. But the audio is at max volume and I can’t get the audio controls to work at all. The non working buttons were again crappy wires that have severed cables on the ends that go into the header in the hat.

So it seems to be almost working but audio is jacked (getting the mixer not found error, and going to the audio settings in rasp config just kicks me back to the main menu for rasp config. )

Still not sure why I can’t power this from the hat as the way it is plugged in now is not workable honestly.

I ordered a canakit power supply as they are a little over 5v and output 3.5A instead of 3A. Hoping it is just not enough powers even though it is the correct specified power supply.

Gah so many issues for something that should just work.

The buttons should work (button presses) with the Plasma disconnected. I’d just leave that unplugged and work on the main problem first. I put a link in your other thread that will let you contact Pimoroni Tech support by e-mail. If you go to the shop page there is a Contact Us link at the bottom of the page. I don’t work for or have any affiliation with Pimoroni, just so you know. ;)

If you have a spare Micro SD card, start over with it, and put the other one aside in a safe place. I think you Picade Hat has an issue with its power on off section.
Are you getting any undervolt (lightning bolt) warnings flashing on screen?

No undervoltage warnings on the screen

Everything seems to work now as long as I am powering the pi directly. But that isn’t very helpful as the power input is on the inside of the board and I can’t put the back on lol. I emailed them asking for help again.

Still no reply from support email days later :(